All motor not working


I very new to setting up the Farmbot. I just recently obtained a Farmbot Genesis v1.2 (uses the arduino+RAMPS shield).

I have wired everything as the documentations. The configurator works fine. I was connected to the internet and can see farmbot in

However when I tried moving the x,y and z axis via control. Nothing moves. I can hear high pitch sound from the motors whilst not moving. I had adjusted the motor control voltage via the screw to give each 1.2V (originally this was set to 0.3-0.4V). I got a movement on the Y and Z axis. X1 is not moving. I tried to change the motor controller between Y and X1 to check if it has problems. But now all my motors are not moving.

Connectivity issues also happens where when I click on control to move the motor, I received an error message “Relative movement failed”. For this I think it is due to the firmware which sometimes became blank, so I have to set it back to v1.2 (arduino/RAMPS). The error message stop, but all 4 motor still does not move at all.

Any help, suggestions and advice are much appreciated.

Thank you.

Let me start by saying I have the 1.4, So I may make references that do not apply to the 1.2. I will leave it to you to determine that and communicate back.

Having said that…
Let’s start with the basics - with all the power off, does the FarmBot (FB) structure move easily along the X & Y axis? (I recommend you disconnect the motor power cables prior to doing this, or move the structure slowly to avoid pushing current from the motors back to the FB electronics - when you move the structure (and motors) they basically become generators.)
Can you move it with very little force? Do you feel any resistance?


Currently my X and Y axis can be pushed even with a gentle force. Z is resisting movement. FYI, the “always on on X and Y has been switched off”.

I suspected the motor driver of being faulty due to my handling of it. (However still have doubts due to something jerky motion at the start of motor commands and high pitch noise coming from the motor even when not moving) Is there a way to how can I verify this with multimeter?

Quick question: when you attached the pulleys, did you leave a gap between the pulley and the motor housing?

Yep. All motors pulley have some gap with the motor housing.

How about if you run the motors with no belts?
Do the motors turn then?
Also, you can de-couple the Z-axis an see if that motor works…

Currently they are all not moving. I had just check X1 motor wire, both red-black and white-yellow received a stable 12V. But when I clicked the control to move x-axis, nothing changed for both 12V. The voltages remain constant like not receiving any signal.

Ok, I am not sure if this will help, but what if you disable the encoders and the just use the “Move” controls in the Control tab to move the motors?

Well that worked! All motors moved very nicely. Encoder problems?

I think so, but not sure.
I had one burn, and you could see and smell the Burt parts (caps near the main IC)
You can try swapping them around, or just get new ones (they are cheap)
If you are unsure, take some good quality pics and post them - maybe we can see burn evidence.

If the motors move nicely with the encoders disabled, then the stepper drivers are fine. If the encoder wiring is correct (the black and dark gray wires are easily mixed up) and the RAMPS shield is fully seated (sometimes a slight separation can cause a disconnect) then it’s likely an encoder settings issue. It may help to enable the encoder position display while troubleshooting, and you may try toggling INVERT ENCODERS first since the motor connections aren’t keyed on the RAMPS shield. See the encoder troubleshooting FAQ for more tips.

Disabling the encoders is a great motor movement troubleshooting tip, and should be the first thing to try in my opinion.

Inverting motors worked. It can move nicely now. I think troubleshooting was difficult because connection between arduino and rasp pi was intermittent (this I havent solve which part is causing it, i have change the cable. Later will try with a different arduino.

1 Like