All settings suddenly lost and no communication with Arduino

My Farmbot was running fine for months, but today for whatever reason all settings in the DEVICE page are blank. Max Speed, Mixed Stepps, etc, all blank. Entering anything into them shows “saving” at the top, but then weh it says “saved” they are blank again. Trying to do any movement results in the message
On the CONTROLS page, X, Y, and Z axes all say position is -1

I tried rebooting, tried unplugging and replugging the USB connection between RasPI and Arduino, nothing. Any ideas what may have happened?

Has your FarmBot installed any new over-the-air updates? Maybe it did not install correctly.

Personally, I think automatic updates should be disabled once you have a stable and working FarmBot. When an update is released, check whether it has any new features or bug fixes that you are after, before installing the update.

I’m not sure if this is related, but I swapped out my arduino last night for an unrelated issue and the new one can not establish commmunication as well. Mine said Failed to execute move_relative: Could not establish communication with arduino: :noproc I reinstalled the original arduino again and same issue.

I hope I’m not conflating the conversation in regards to your issue, but I just went on the message board to look for causes and came upon this.

Auto update to 5.0 seems to have magically fixed the issue…

1 Like