Anyone else out there experiencing log on issues?


#1

I get keep getting the ever-feared “Sync Unknown” message…
Any one else?
At about 12:30 to 12:45 pm PST today?

Just want to rule out the network beyond the firewall…


#2

Dont know if its related but my farmbot has been disconnected since last night and is showing the same thing.

Has your’s reconnected yet? Mine hasn’t


#3

@MCbigminer @Intelbotfarmer I will investigate this issue today. Thanks for letting me know about it.


#4

I just got back from the Farm(Bot) and I was still unable to get it to connect.
The common returned error is “TLS Certificate” error (I can get a screen cap, but this is the same error from a few weeks/month or so ago).
Observed behavior:

  1. From the Configurator, I would enter all the info as before (“Wired” connection, School NTP IP’s, School domain name, school Nameserver IP’s, Choose FB 1.4, Enter the FB account & pw)
  2. The Configurator would complete,
  3. The “farmbot-xxxx” SSID would stop being broadcast
  4. The blue LED would flash for a minute or so
  5. The blue LED would turn off for a few seconds (10 or 15)
  6. The blue LED would start to flash again
  7. The “farmbot-xxxx” SSID would start to be broadcast again
  8. After connecting to the FB SSID, the error message was displayed (last attempt failed - TLS stuff)
  9. One different observation - When I tried to connect using WiFi to my phone (mobile hotspot), the blue LED would continue to flash and the FarmBot SSID was never re-enabled/re-broadcast. This is weird because it never connected to the hotspot…

I tried a multitude of steps:

  1. Started from a freshly imaged FBOS (multiple times) - Same failing results
  2. I confirmed with the school district IT Guy that all FB traffic to and from the FB IP was going through - Confirmed
  3. I tried other accounts (I have two I use for testing - Same failing results
  4. I attempted use my cell phone (Samsung/android/T-Mobile) with mobile hotspot - Could not connect
    a) This one I cant quite wrap my head around. Why the Configurator cannot connect to this is beyond me. I tried with and with out a mobile hotspot password - no connection. I do remember the last time I tried this i had a few fails, then one time it did connect. I tried using the default settings as well as entering just the"0.ntp.pool.org" & “1.ntp.pool.org” info (nothing else) This did produce the one different error “NXDOMAIN”, which is strange, because it still never connected to the hotspot…

I am at work for the day, but I plan on heading over around 4p or 5p today (PST) to try more “stuff”. If you have any tips, I am your willing crash test dummy!


#5

@Intelbotfarmer Do you think this could be related to the unexpected errors you hit a few weeks ago?

We did do a deploy of just the web app yesterday (minor bug fixes- no changes to FBOS) our device usage stats appear to be normal, so I would imagine this is local to the bot rather than a widespread issue. I will keep my eyes on it.

Farmbot v8 will be adding some updates to the network stack plus some reporting tools for under-connected devices, which will hopefully give us more data points on why this is acting up.


#6

Yes, It seems to be acting the same (not completing the configurator) as the last time.
One step that I think may have had impact was anything that has to do with certificates and the account from your end.
Is there any reset action that can be done on your end without affecting the sequences, configuration or settings of our FB?
Thinking Certificate stuff here…

Otherwise, I will go bang on it this afternoon - I will overcome!
And I really want to know why the mobile Hotspot dose not seem to take…
Thanks!
~Tony


#7

Ok, I spent a couple hours trying to get the bot to connect to any connection point this afternoon…
I tried two different mobile hotspots ( both android)
I tried multiple FB accounts, and one brand new one.
For the most part I got “TLS Certificate” errors.
I got “NXDOMAIN” errors when returning to the Configurator after failed mobile hotspot attempts.

I will start again in the am - I kinda need to get the FB back online before Monday - I am chaperoning 60 6th grade students for a week long trip to Yosemite…

Any help, advice or pointing out the obvious would be most welcome - at this point I feel like I am just re-trying the same steps and hoping for a different outcome - I think this is the definition of insanity, but I might be too far gone to notice or care… :wink:


#8

Ok, just got back from the FarmBot again…
I tried:

  1. A new MicroSD card (16GB SanDisk UltraPLUS) - Same failing signatures
  2. FBOS 7.0.0 - Same failing signatures
  3. Attempting with just the RazPi (Farmduino, buttons/LED & USB Cam disconnected) - Same failing signatures

At this point, as little sense as it makes, I am thinking that I should try another RazPi 3

Thoughts?
@RickCarlino


#9

Back out at the Bot…
Still cant connect to a mobile hotspot with Configurator in 7.0.1
I tried a new Raspberry Pi 3B+ (brand new - purchased today)
I could not get the RazPi to connect to the hotspot at all.
Tried with bare-bones RazPi - nothing but the power cable from Farmduino.
I am starting to suspect that the FBOS for 7.0.1 may not like WiFi hotspots…


#10

I got the FB to connect yesterday!:grinning::+1::ok_hand:
I am not sure, but I am suspecting iOS (Apple).
It was not until I went through the entire setup using ONLY my Android phone and Win10 laptop that I had success.
A couple-few other details.
I had my mobile hotspot SSID and my FarmBot user account name pretty similar. They both had the same three letters at the front. I renamed the mobile hotspot to something completely new and different, as well as using only Android, and then I was able to use the Configurator to connect to the hotspot. After that, I logged on to the Web UI on my win10 machine, did a factory reset, re-ran the Configurator using the hotspot (Android), set up the wired connection, and it has been smooth sailing so far!
Any chance iOS is doing something funny? (@RickCarlino)


#11

@Intelbotfarmer That’s great to hear!

Any chance iOS is doing something funny?

That’s the first time we’ve received such a report, but it is possible. I will pass the information along and see.


#12

One thing I noticed while running the Configurator on my iPad - even though I DID NOT populate the “ID_RSA.PUB” field with the FB account, when I return to the Configurator after a failed attempt this field is auto-populated with that info (example: “MyAccount@gmail.com”)

I know this happened with Chrome on iOS, and pretty sure with Safari too (but I don’t want to re-create the fail now that everything is working… :expressionless:

Not sure if this is another clue…