Applying OTA update let FarmBot stuck in a boot loop

Hello, we currently have an issue with our FarmBot which crashes/is stuck in a boot loop after applying an OTA update. I noticed this now multiple time in this month. Two times I have flashed the Version 9.1.1 of the OS image onto the SD card and reconfigured the FarmBot, but now it has happened again so that I am wondering what is wrong and how could this problem be solved, because which options do I have to fix this?

The boot loop was detected, by connecting the RaspberryPi of the FarmBot to a Monitor. A video of the output on the monitor:

In the log in the web app I can see five times: “Busy - Applying OTA update” and after this the no further log messages exists.

The FarmBot is connected via Ethernet and gets it’s IP address configuration via DHCP. We use a custom NTP time server.

@TH781 To make sure I am understanding the situation correctly, you have a device that works properly when you flash 9.1.1 to an SD Card and manually install, but once the device comes online and tries to do an over-the-air (OTA) update to the newer 9.1.2 version it starts to boot loop? Were you able to manually flash the newer version 9.1.2 to the SD Card (via manual update rather than over-the-air update), or did that version have issues also?

I will still need to investigate the cause of your problems, but in order to re-gain control of your device you can temporarily disable “Farmbot OS Auto Update” in the device panel of your account. I am offering this advice under the assumption that your device is booting properly and only begins a boot loop after applying over-the-air updates. Please let me know if this is not the case.


EDIT: A previous version of the preceding message referenced an incorrect setting. I apologize for any confusion this may have caused.

You are right, the automatic update did fail. Flashing the 9.1.2 onto the SD card works and the FarmBot is running, but this also worked with the 9.1.1. The automatic update seems to cause the boot loop.

I updated to version 9.1.1, because I didn’t notice, that a newer version was available (took the version I already had downloaded a few days earlier).

@TH781 I am glad that you have at least re-gained control of your device, but I still will need to investigate why OTAs are not working for you (thanks again for bringing this to our attention).

In the meantime, I would highly recommend disabling OTAs until the root cause is isolated. We intend to do an FBOS release in the next week or two, which would trigger an OTA.

In case it may help, I got exactly the same problem as TH781. I disable the auto update for the time being.

Thanks for investigating.