Axis movement issues with videos

Hey guys, having trouble with basically every axis for a different reason. Trying to use the encoders so that I can get a reliable movement state because in my area there are big temp / humidity swings that seem to already be affecting some of the calibration. Here’s the videos:

Not sure why the motor is making this noise. When first installed, it would move down and then up to some distance, but after a certain distance it would move up a few cm then make a weird noise and start moving down three times as many cm before shutting off. Now it just does not want to move except maybe 1 in 5 attempts.

When Homing X, it seems to stop appropriately after reaching resistance. For Y, both Calibrate and Home go the same direction, and both keep running after hitting resistance. The belt is not slipping so I’m not sure why it isn’t ending.

I think part of this is a need to equalize, but shouldn’t the encoders be registering the hiccups that happen during this travel? I don’t see any differences in the positions when encoders are on vs off for any axis.

Thanks for your help!

Can you take a picture of your RAMPS board with the encoder and motor driver cables?

Also, has it always been doing this or is it a recent change? What version of SW are you currently running and if it was working what version was that?

The Z-axis issue looks like not enough power goes to the motor for smooth motion. This means you have to adjust the screw on the stepper driver. There are guides for that to do that without destroying anything.

The Y-axis homing issue I haven’t seen in 3.1.6 except when with increased missed step and decay parameters.

For the X-axis, the encoders only detect stalling, not position. Well, they do detect position but not good enough yet in this version to be usable in all conditions.

Had to shoot one on the way to work for the RAMPS connections:
Google Photos

Tim, thanks for the reply, do you know where a good guide would be? For Y, what would a normal missed step and decay params look like so I can compare. For X, makes sense, it just seems that this isn’t quite perfect enough yet to depend on exact sequences.

This guide has been recommended:

The default miss/decay is 10/10. That seems to work for me. It might be possible you used the green-black cable instead of the green cable for the Y enocder, but that just might be a shadow in the pic. It can also help sometimes to use the ‘invert encoder’ settings.