Brand new farmbot not working!


#1

hey guys,

brought a farmbot a couple of weeks ago. got it all setup and installed and it wont move!!

looking at the logs i see 2 things that may cause a problem

  1. UART handler died: :normal
  2. Firmware version 6.4.0.G is not in expected versions: [“6.4.1.F”, “6.4.1.R”, “6.4.1.G”]

when looking under device - connectivity the line between raspberry pi and arduino is red. never seen it green.
on the farmdunio after being powered for a short time the tx light stays on.


#2

Have you tried rebooting, or factory resetting and configuring again?


#3

i have tried that. unfortunate still the same issues.


#4

i have also tried a different usb cable from the pi to farmdunio. no go there ether. and everything but the power and usbs unplugged from the dunio


#5

While configurating, did you see any response from the farmduino in the process where the firmware is being flashed? Usually the RX/TX leds should flicker a lot.

Did you also try to plug the USB cable into a different port at the raspberry?


#6

hey Ascend,

i did try different ports on the raspberry. but i didnt think to look at the dunio when flashing. will try that in the morning.


#7

Alright, this might indicate if there is no connection between Raspberry and Farmduino right from the beginning, or if there is something wrong with the communication between firmware and OS. Your log sounds like that there is a firmware flashed with the version 6.4.0.G which would be outdated since a few months.

Which FarmBot OS version did you flash on your SD-card?


#8

version 7.0.0


#9

Version 7.0.0 should flash you the current firmware version on the farmduino, which obviously didn’t happen. The only way I could explain the outdated firmware version is, that maybe the farmduino was tested before shipping with this version.

In this case the firmware flash didn’t work at configuration. I’m not sure how the OS reacts to this, maybe this leads to the " UART handler died: :normal " error which may cause the connectivity tab to show that there is no connection between raspberry and farmduino.

Maybe one of these may help you:

  • Flash SD-card again with the newest version
  • Factory reset and configurate again with an eye at the farmduino if something happens.
  • Flash the firmware manually via Arduino IDE into the farmduino. This one is more time consuming and usually should not be necessary.

#10

Ok. have tried the reflash.
Will try factory reset while watching the farmdunio. :crossed_fingers:
If that doesnt work will try the andiuno ide flash.

Thanks for the help Ascend.


#11

tried the factory reset and watched it. there was almost no flashing on the tx/rx. flashed together once every second.
tried to flash via arduino IDE. that didnt even make the tx/rx flash and got this error

Sketch uses 42130 bytes (16%) of program storage space. Maximum is 253952 bytes.
Global variables use 2787 bytes (34%) of dynamic memory, leaving 5405 bytes for local variables. Maximum is 8192 bytes.
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
An error occurred while uploading the sketch


#12

Oh this does not sound good. I’ve had similar issues with my Mega2560 but I replaced it for a different reason, now this issue is gone. I’ve read in the arduino forum, that clicking the Reset button right before the upload starts could get the bootloader in sync again. Surprisingly this helped and I was able to upload the firmware.

Here you can read more on stackoverflow.

Btw: I assume that you selected the right board (arduino mega 2560) and the right com port in arduino IDE.


#13

yep, mega 2560
tried the reset button (press/ long press / holding while power on) when uploading.
all i got was the rx/tx flashing together once every second.


#14

for anyone that is checking out this post. Rory has sent me a new farmdunio. it is now moving and connectivity is all green :slight_smile: thanks for all the help on this issue


#15

Just Rory beeing such a nice guy :+1: Glad that your bot is running now!