Camera does not work

My camera can’t take pictures. When I click the take a picture button, it will prompt “success, process now, the result is usually available in one minute”. But it doesn’t show up on my screen, no matter how long you wait. I also tried to change the USB port and restart my farmbot. But it doesn’t work.

I plan to calibrate the camera today. I don’t know how to deal with this problem. please

I tried to click these two buttons, but it didn’t seem to work

Same thing for me. This might be related to the issues on google services but they are working on it.

Thanks,I thought there was something wrong with my operation.

Same issue here…

I had an OTA update last night. My camera worked before the update, and after the update I have this issue.

v1.5 here.

@midtec2005 what is the exact error you are receiving? And what are the last log entries after you triggered the farmware?

@midtec2005 We’re noticing an uptick in failed OTAs for the 9.2.2 release. This has been particularly difficult for us to isolate because the devices at FarmBot HQ seem to accept OTA updates without issue. We are suspicious that there is an environmental or configuration issue at play, but it is too soon for us to say definitively.

When I attempt to take a photo on your device remotely, I receive a warning about possible data corruption. You will need to re-flash and re-configurate the device while we continue to work towards isolating the cause of the problem. Until we have isolated the cause of the issue, you may also wish to disable auto-updates to avoid unexpected downtime.

Please let me know if the issue persists after a manual reconfiguration and thank you for your patience as we investigate this matter.

1 Like

Okay, I’m unsure of when I’ll get the reflash done but I’ll let you know when I do.

1 Like

Quick update for you: I reflashed the firmware and the behavior persisted. Then I did a factory reset and still have the problem.

I have not tried removing the SD card and reinstalling the OS, should I?


Yes, manually re-flashing from a desktop computer (by removing the SD Card) is required. If this does not fix the issue I will contact you privately for troubleshooting.

That did the trick. Let me know if you want me to do anything to help you figure out what happened.

I’m glad you’re back online @midtec2005. We will keep you posted about our progress towards a fix via the newsletter. For the time being, it may be a good idea to uncheck the “AUTO UPDATE” switch in the device panel. It seems that this issue affects some devices more than others.