Can not connect to mqtt

hello,i have a quetion,my farmbot can’t connect to mqtt,and the network is ok,and yesterday connected successfuly only once,what should i do ? thanks ,come from your chinese friend

1 Like

Logging out and logging in again usually works for me.

i did it like this,but the problem is still there,log:

Farmbot[84]: 2017-10-11 10:01:14.196 [error] module=Farmbot.Transport.GenMqtt.Client function=on_connect_error/2 line=52 >> Failed to connect to mqtt :server_not_found

Farmbot[84]: 2017-10-11 10:03:24.436 [error] >> Failed to connect to mqtt :server_not_found

can you tell me why?

I created my sd img on my 7 geg sd and inserted it after then loading an initializing my Gmail account and password… I then turned on my farmbot on and tried to log in. the picture is included. Whether farmbot is up and running or turned off I get the same screen at login. I have passwords and control of my router. I have checked the simple. "rj45 connections, passwords for the console. configuration of the console… three times. I am getting the same screen.

My router has been completely reset several weeks ago and I have been able to connect to my farmbot using 4.0.2. I have tried turning off the firewall on my win10 terminal. I do connect wirelesly for the console configuration. I then change over to my wire, “rj45”. I can ping all around.

is there a new version of the console for 5.0.4 or anything else I should be changing?

The rpi3 is blinking green and I can see the packets reflected on the router. The rpi3 is solid red as usual. this is a upgrade attempt from 5.0.2.

my next step is to go back to 5.0.2, but somewhere I sense that is not a good idea because of up grades that might have occurred in the mean time.

Please advise.


Adding an also. I have also deleted my crome … farmbot … automatic login so as to not be playing with previous passwords. Is there anything on the cloud connection that would interfere with new passwords?



I have met the same issue. While the wifi config page didn’t pop up again, I suppose it have successfully connected to the cloud. But on “” page, the device shows not connected. Is there any further debug method try to help locate issue? BTW, I use a 1.2 version kit and farmbot-rpi3-5.0.2.img.

A widget to display connection debug information has been released in today’s software update. See the Connectivity widget on the Device page.

Also, try using the latest FarmBot OS image, linked to in step one of the installation instructions.

i use loal server and my farmbot can connect to it successfully.

Can we see a screen shot of the connectivity panel?

It is in the “Device” page and looks like this:


1 Like