Can Not Update 4.0.1

Can Not Update 4.0.1 about 1 hour the FarmBot is offline.

It seems that your bot is offline/disconnected.
Check it’s connectivity and they try to update.

I have the same problem. The bot is online and the Update do not want start.

reconnected and click update it Erro

Similar problem. 4.0.1 seems to download (lights on the router flicker for a while) but it doesn’t install. Have tried with both automatic update enabled and disabled and the update button for 2 days. Am going to pull the SD card and flash the new image unless there are other ideas to try.


This usually happens from pressing the button more than once.
There are no logs right now while the bot is downloading an update right now, but it is working. I’m working on building a logger for this feature so it doesn’t look like the bot is stuck. For now, you should reboot, then when farmbot is back online you should click the button once.
if you see "Farmbot has found a ndew Operating System update: " it is downloading. Sometimes it takes a long time so just wait and eventually Farmbot will reboot.

I have reboot and click the update once. it can not to update all day long

the same issue happens by me. After 2 days no update…

I had the same thing… gave up and flashed the SD with new OS 4.0.1 manually :frowning:

in my case, even after flashing manually, the bot just won’t come online with 4.0.1, it still works with 3.1.6, tried the upgrade 4 times already.