Can't connect through Wifi, only through ethernet after updating to ver.7


#21

Okay so i’ve had a read through your logs. There is nothing that leads me to believe this is power related. I believe this to be DNS related. (as indicated by the nxdomain error.)

In your logs i can see a particular dns server being configured by either you OR your router. I configured my local device to use the same DNS server as your device is using, and i too received nxdomains as well as ridiculously high latency resulting in timeout errors.

Are you on a enterprise network of some sort? It would seem to me that a firewall rule has changed or something. The reason i ask is because you mention

I just installed a new electronics box

The would mean that the mac address of the farmbot’s raspberry pi would be different right? Could the new rpi be causing issues?


#22

thanks for the update. the farmbot is set up at an university, so to avoid firewall problems, the IT department set up a separate router close to the farmbots (within 10 meters) that is not password protected or restricted.

When I set up my 3 farmbots for the first time last august, I had them connected to this router through wifi. It worked well up until march this year. When I updated one of them to v.7, thats when it couldn’t connect through the same wifi. I temporarily used an ethernet cable connected to the router and it worked, but when the farmbot started acting up for unknown reasons (as described in earlier posts), I decided to replace the farmbot with a new electronics box with an all new raspberry pi and other hardware in the box- so yes, the Mac address will be different.

After the replacement with the new raspberry pi, I flashed it with v.6.4.9 and it worked again on wifi connected through the same router. When it auto-updated to v.7 last week, that’s when the same thing happened as before - couldn’t connect through wifi.

So to sum up:
August to March - newly set up farmbot running on v.6.4.9./6.4.13
March to last week - a 2nd, new electronics box with new hardware installed (worked with v.6.4.9).
Last week to present - same electronics box (works with v.7.0.1 only through ethernet cable)

I don’t know what I’ve done to configure the DNS server or cause my router to configure it…is there something I can do to correct this?

Appreciate your help!


#23

@Connor I spoke to our IT guys at the university. This is what they told me:

Regarding the DNS server, the university uses our own DNS server which is not open to traffic coming from other countries (we are in Taiwan), and that is maybe why you got high latency when you configured your device to use the same DNS server as my device, resulting in timeout errors.

To see if it’s a DNS issue, they made a change and used google in the DNS server for me to try, but it still doesn’t work, I still couldn’t connect through wifi. They cannot think of anything else to try. No changes have been made to the firewall rules or any related to it. Their view is that because I could connect through wifi using v.6.4.9, this must mean the issue is not with the university wifi network…

Just as a test, I flashed all versions from 6.4.9 to 6.4.13 and tried each version on my farmbot. All versions except 6.4.10. (certificate expired problem) could connect through wifi immediately. After trying all of these versions, I flashed 7.0.1, and the same thing happened - cannot connect through wifi.

However, with v.6.4.9 - 6.4.13, all those that could connect through wifi had a sync error problem (similar to what has been mentioned in another post), but that’s another problem for another day. I am just really puzzled with this wifi issue.

From what you mentioned in your last post:

should I try using another rpi and see if it works?
I would be really grateful if you could provide any other ideas or solutions to this problem, pleeeeeease…


#24

Could you try to use a mobile hot spot to configure FarmBot as a test? if it can connect with that, it would be indicative of something on your network causing issues.

It’s weird that 6.xx releases work, but 7.xx doesn’t. I’m looking this up right now, but i don’t think there has been any real changes since 6.4.13.


#25

@Connor I forgot to mention it previously, but I did try using a mobile hotspot (without password) a few days ago, it also didn’t work. I will test it a few more times just in case. Will give an update on it later.

Also, I thought I might as well give it a try so I’ve ordered a new rpi, once I have it, I’ll swap out the current one and see what happens.

Thanks for looking into it.:smiley:


#26

@Connor Here is an update:

  1. I tried using my mobile hotspot several times, the result is the same.
  2. I got the IT guys to come change the router, new wifi, still doesn’t work.
  3. Because of “sync error” with the other 2 farmbots, I decided to flash v.7.0.1. to both of them. Now all 3 farmbots are on v.7.0.1. And all 3 have the same problem - works fine with ethernet cable only. All 3 cannot connect through wifi.
  4. I tried mobile hotspot and new router, new wifi on all 3 farmbots. None of them work.

I was thinking maybe this problem was specific to that first farmbot, but it is definitely not. All 3 has the exact same wifi issue now, so it is unlikely that the rpi is causing it.

It really is happening only after updating to v.7.0.1. I am wondering if anyone else has the same problem as me? or is everyone running through ethernet? Any suggestions from the forum would be appreciated!

Any updates from you Connor? thanks


#27

What country are you in? It’s possible there is too much latency or maybe WiFi Regulatory domain is breaking things?


#28

@connor
I think he is in Taiwan…
:wink:


#29

@Connor yes, I am in Taiwan. I will check with the IT guys about the regulatory domain, will get back to you on it.


#30

@Connor Problem solved!!!:smiley:

Let me explain: In the past week I got a few students from the computer science department to look into it. They looked into the regulatory domain issue and hooked up the rpi to look into it in detail, some were able to connect to it through mobile hotspots and other wifi networks, but still couldn’t pin point the exact reason why some worked and some didn’t.

It turns out it wasn’t a particularly technical problem. Today it dawned on us that I MUST set a password for the wifi. It won’t connect without a password! I really didn’t know about this. The previous v.6.4.xx wouldn’t work on the usual university network that requires a login name and password, so we specifically had to set up a separate router without a password for it to work.

So because of that we had it in our heads that there must not be a password for it to connect. Now, it turns out with v.7.0.1, it will only connect if there is a password set for the wifi. :sob:

I don’t know if ‘connecting to wifi only works if there is a password set up’ is considered a common thing. Is this normal?

I just want to thank you for your patience and help in trying to figure out the problem. I really appreciate it!