Configuration and connection problems


#1

Good morning, for several months now I can no longer connect the farmbot to the wifi network.
I have done all the advice that I have been given on this forum, I changed language to the browser and the operating system, I replaced both the raspberry and the arduino, I installed the farmbotOS in the microsd card, but unfortunately without ever having success.
Furthermore, I requested an intervention from the operator to fix the wifi network. I use 2 wifi networks, one inside the house and one outside with a device that increases the range of the signal. All my devices, PCs, smartphones and tablets connect and work with both networks.
All except the farmbot located outside the house. The only time I was able to connect was when I brought the two cards (raspberry and arduino) inside the house, at which point I managed to connect to the internal wifi.
I do not know what else I can do, if you have any other suggestions I’ll be happy to keep trying, otherwise I’m starting to think about dismantling the farmbot and looking for someone else who wants to use it.
Greetings
Silvio Palombo


#2

Have you tried taking one of the other “known good” Wi-Fi devices out to the location of the FB plot?
Or doing a signal strength check in that area?


#3

Hello and thanks for the advice, when I’m setting up I’m in front of the farmbot, and the various devices I’ve used all have excellent wifi reception.
Before the operator’s intervention, reception was average, so I requested a device that increases the signal range. Greetings
Silvio


#4

Hi, these days I have carried out other tests to solve my problem. It seems that the connection to the farmbot works with devices such as access points and range extender of an economic type, not suitable for external use.
But when I tried using a special device for outdoor use, powered by POE (like the device installed by the operator), I found myself faced with the usual problem.
As a further check, I installed the latest version of Raspbian in the Raspberry pi 3. I can connect to the Wifi via the external device and surf very well on the internet.
Is there any incompatibility between POE devices and the FarmbotOS?


#5

POE is only supported on a more recent Raspberry Pi board (Raspberry Pi model 3 B+) and then it also requires a PoE hardware “HAT” module attached. The FB team are shipping the older RPi 3 B a.t.m.
The newer RPi 3 B+ works fine to run the FarmBot.