Configuration Errors? Cannot re-configure


#1

We were able to connect to the RPi Wifi (farmbot-xxxx) and run through the configurator ONCE, but our school’s network apparently won’t allow the device to connect (Bot not connecting in my.farmbot.io).
When we try re-connecting to the farmbot-xxxx Wifi to re-run the configurator, it kicks the connecting computer off farmbot-xxxx every time we open the webpage (192.168.24.1).
We tried a new RPi I had handy, and it allowed connection once (but again, our school IT guy gave us bad advice about which school network to connect to, and/or proper settings to connect). Same thing–first time through worked, when we try to re-run the configurator it consistently bounces the computer off farmbot-xxxx.
We tried flashing (using Etcher as recommended) a different SD card with farmbot-rpi3-7.0.1 (downloaded from GitHub at https://github.com/FarmBot/farmbot_os/releases/download/v7.0.1/farmbot-rpi3-7.0.1.img), and restart the RPi with that new card, but it didn’t change anything.
I would be happy to configure by pulling the RPi and connecting a monitor, mouse, and keyboard if there are instructions for that somewhere–it seems this ‘clever’ idea of configuring through farmbot-xxxx Wifi is more trouble than it it worth…


#2

Well, this was interesting. Turns out a security feature of the school Wifi launches something similar to a denial of service attack on any unregistered device that acts a web proxy (which is what the Farmbot RPi configurator does).
I discovered this when I pulled the RPi and took it home to test–it worked perfectly!
The irony is that TWO different IT guys sat in the sun trying to figure out the issue on two different occasions for a total of 4 hours and it never occurred to them. I insisted something about their system was blocking, and they even denied it (at first). Now they registered the device and it seems to be just fine. These people are professionals. Go figure.
Also, one of them stated he had read ALL of Farmbot’s software literature, and then wanted it to connect to the enterprise network. Even I know it can’t do that! I just wish they wouldnt lie to us about things…