Connect Farmbot to local server by ethernet cable

Hello everyone,

I’m struggling to get my raspberry connected with my local server. The Server is stored inside Farmbots electronics box, so it would make sense to connect the Raspy with an ethernet cable. Here is an overview of my current setup:

Browser ------ WiFi ----- Server ------ Eth port ----- Raspberry

I’ve set the API and MQTT adresses in the .env to the servers Ethernet IP ( where the Raspy is plugged in and routed the connection with IPtables from the Servers WiFi IP ( to the ethernet one ( So I have access from the browser. So I am able to connect to the server with my browser, but I can’t get the Raspy to connect the WebApp through the ethernet port. The servers address in the Server field of the configurator is filled with Am I missing some settings in the FB configurator? In the logs of the configurator are always 404 sent in 1ms logs, that lead me to think that there is no connection to the Servers IP.

I’ve also tried setting the API and MQTT address to the WiFis IP which works great and lets me connect the Raspberry via WiFi. So its seems to run fine on server side.

There seems to be a abandoned similar thread already. @FarmbotESEO did you find a solution?

Hi @Ascend
Sounds like this should work . . so some questions to tease out more detail of your setup

That’s a machine which hosts your own WebApp ?

Ok, so how is that Ethernet ( wired ) link configured on the Raspberry Pi ?
If it’s ipv4_method is “dhcp” then you’ll need some host in the network to respond with a sensible configuration message. I use “static” config for my wired Ethernet and that works completely reliably.

By “logs of the configurator”, I assume you’re at the Raspberry Pi serial console ?
HTTP 404, 404 Not Found, 404, Page Not Found, or Server Not Found suggests that the Configurator is being sent a request that it’s unable to handle.

Hey @jsimmonds,
thanks for responding. After further inspection it looks like there is no proper connection between the WebApp hosting device and the Raspberry, because its not showing up when running network scanning tools on the “Server device” (WebApp host). Also doing a ping command from the server to Raspberries IP after onfiguration does not work, all packets lost.

Yes that is true, I’ve got a small x86 based machine that runs the WebApp pretty fine and also works if the Raspberry is connected via WiFi (through the AP of the router).

That’s great to hear that it works on your device, so I’ve got soem hope now :slight_smile: . When configurating the Raspberry via FBOS configurator I’ve set the ipv4_method to static and typed in a random IP with the first 3 blocks being the same as the “Server device ethernet port”, e.g:
The Subnetmask is set to and the gateway is set the same as in the Server ethernet port config -
My Server runs on Ubuntu 18.04 Server, so I’ve got to set the network setting via netplan. I’ve put the config in the spoiler below so that post will not be that long.

Open this for netplan configuration on serverside

version: 2
renderer: networkd
dhcp4: no
dhcp6: no
addresses: []
optional: true
dhcp4: true

I didn’t connect to the raspberry directly yet, but I’ll do that to see what exactly is going on. Thanks for that hint :slight_smile: .
The mentioned logs are saved on the Raspberry and can be accessed at With a fresh flashed SD-card the logs are saved and shown really nice, but when the table is full, no new logs are added and only the old logs are shown. But that was the easiest attempt to see what is going wrong.

@jsimmonds is your Raspberry connected to a local server or are you connecting to

Alright, looks like I’ve got my raspberry connected with an older version of FarmbotOS. 8.2.4 is working and 9.2.0 is not! I’ve noticed some differences on the Raspberries HDMI output stream indicating that plugging/pulling the eth cable does not have any effect (no log entries).

I’ll try different versions and see if I can find out anything.

My FBOS runs on a Raspberry Pi 3 B Plus wired directly to the back of an Apple Airport Extreme router in the home network and I’m using the WebApp on so that I always get the freshest software :slight_smile:

1 Like

Maybe try v9.2.2 . . v9.2.0.didn’t last long due to various issues ( mainly firmware ).

1 Like