Connection Issues with Farmbot

Hello Everybody,
we are having issues connecting to the farmbot. For the past two days the farmbot has not been connecting to the web app before that it worked perfectly. We tried re-flashing the sd card as suggested in some of the forums but it still wont connect. The farmbot will not display its farmbot-xxxxx wifi either so we cant even reconfigure it. Does anybody have any clue as to what the problem may be, any help is good. Thanks

Do you see red and green lights on the Raspberry Pi? What are they doing?

Are you using Etcher to flash FarmBot OS v6.0.1 onto the SD card?

Have you tried unplugging any USB devices before powering the Pi?

yes I do see red and green lights. The red stays constantly on while the green flashes on and off for a second.

We did use etcher to flash Farmbot v6.0.1 on the SD card.

We have tried unplugging any USB devices before powering the pi.

It still does same thing

Is there anything else you may recommend checking or any opinions you may have of what we may do? thanks

Do you have any other micro SD cards around? You could try using a different SD card to see if that’s the issue. If the flash to the card was successful, you should see the farmbot-xxxx network. If you have another pi, that could be something to try as well.

Is the green LED blinking steadily?

The led is blinking steadily.

We tried another SD card and the farmbot wifi now shows. We configured it using the website and it seemed to configure alright, but the farmbot still wont connect to the web app. after looking at the device page in the web app it still says that it is disconnected.

In the device page It says that the browser is connected to the web app and message broker, but says that the message broker and webapp are not connected to the farmbot. It also says that the Raspberry pi and arduino are not connected to each other.

I just saw a video from Rory, explaining how to configure. I followed his steps exactly. He mentions that the farmbot wifi should not exist after configuration. After I configure, our farmbot wifi still exists. Only difference is that after configuration it will not let me reconfigure. When I type it takes me to an error page. Could that be anything you may have heard of? Thank you

What does the error page say?

it says:

This site can’t be reached refused to connect.
Checking the connection
Checking the proxy and the firewall

Update: I checked the device page again and it says the web app say the farmbot about 30 minutes ago but the message broker has yet to connect with the farmbot.

Hello again, I just thought of something, when I configure should I choose RAMPS(v.1.2) or Farmduino(v1.3). The Farmbot we are using is v1.2 but we downloaded the latest farmbot img file I believe is 6.0.1. I have been choosing RAMPS for the configurator but should I choose Farmduino?

You should be using v1.2 for a v1.2 FarmBot.

Can you connect to the farmbot-xxxx WiFi network and navigate to in a web browser? Do you get the same error page?

I just typed in the, and it takes me to configuration and in configuration there was an error message that said I should show someone from FarmBot.
The error message was:

Last shutdown reason: Failed to start child: Elixir.Farmbot.Firmware reason: {:handler_init, {:error, :enoent}} This is likely a bug. Please copy or screenshot this error and send it to the Farmbot developers.
environment: prod

source_ref: 06966605e934e566eb4224c16792adeab28fccf8

target: rpi3


[ {Farmbot, :start, 2, [file: ‘lib/farmbot.ex’, line: 22]},

{:application_master, :start_it_old, 4, [file: ‘application_master.erl’, line: 273]}]

Do you have any idea what this means? Thank you.

Can you try the instructions here?

I just tried this. After the update gets to 100% it never changes to UP_TO_DATE. It stays at UPDATE and in the logs it says “CS Failed- [check_updates] Failed to check for updates”

Have you tried restarting FarmBot?

I just tried restarting it. It now says UP_TO_DATE and when I plug the arduino back in the web app gets says:
Firmware parser error: argument error.

Then I restart the farmbot it like it says in step 4 with the arduino still plugged in and when it comes back up, the webapp still does not connect

We left it on all night with the srduino connected, the web app kept repeating the same logs:
“Firmware not initialized. Waiting for r88 message” and
“ Firmware parser error: argument error”

You will need to update the firmware installed on your Arduino.

Option 1: You can try selecting a different value in the FIRMWARE dropdown in the Device widget.

Option 2: Factory reset FarmBot and reconfigure.

Option 3: Plug the Arduino into a computer and upload a firmware using the Arduino IDE.

Hello again,
I just wanted to give an update. We tried option 2, factory reset. The first two times we tried it, it would configure but would not recognize the Arduino as connected even when it was. The third time we tried it, we decided to unplug the farmbot after factory reseting it and when we plugged it back in, we configured it and after about 15 minutes it synced perfectly. We left it on overnight to see how long it would stay connected. It seems to be working perfectly, option 2 definitely did the trick. Thank you so much Gabriel for all your help, it is very much appreciated


I had many of these same issues. What finally worked for me was manually entering the wifi network name when configuring. Sounds crazy but it worked for me.

Hello @Gabriel, we again are having issues connecting the farmbot to the webapp. When we configure it, the farmbot wifi will reappear but will not allow us to set it up. We have tried reflashing it and the same thing happens. WE have also tried buying a new SD card and the same issue persisits. Are there any other recommendations that you may have?