Connectivity Issues v1.2 Farmbot


#1

Hi,

I know there is probably a lot of posts on this topic, and I´ve searched a lot of them, but none of the suggestions have worked so far.

The farmbot has been working fine until mid April, and due to being busy I haven’t been able to look at it before now. I manage to set it up correctly after flashing the new OS to the SD card. I choose RAMPS/Arduino, and the Raspberry lights are correct, the red power light is on and the other green light is flashing randomly.

But it just can’t seem to connect to the internet. The signal is strong, the wifi router is just a couple of meters away. And it all worked before, exactly the same way. What I find strange is that it shows a yellow line between the Arduino and Raspberry, as if they can’t find each other. All the cables are secured and nothing has been tampered with. I tried several different wifi, numerous re-flashings and reconfigurations. Any suggestions? Is the Raspberry wifi just not working?


#2

Focusing on the RaPi to Arduino connectivity: I had an issue with this once. Out of sheer “Well, I haven’t tried this yet”, I fully detached then reattached the RAMPS shield from the Arduino. For whatever reason, this fixed the issue. I don’t have a satisfying explanation for why this worked.

Focusing on WiFi, is the FB going back into setup mode at all? If so, that should provide some useful information on that setup page (perhaps your login credentials for your FB account are incorrect?).


#3

Adding on what @fuzzynickel said:

the Raspberry Pi <-> Arduino connection state will not be available while RPI <-> Web App connection is down. (Since that is needed to check Arduino connection)