Controls buttons work once then are all light grey

I have a v1.2 farm bot that I haven’t used for a long time. I re-installed v14 and its seems to work just fine until I press a control button. The device moves as expected but once complete the buttons remain light grey and I can not do anything. Resetting the devices it returns back to normal, works once then does not. Any ideas?

Hi @chrisb just checking your running FBOS and Arduino software versions . . FarmbotOS v14.7.0 and Arduino firmware v6.6.20 , is that true ?

Does the Web App say that Farmbot is offline ?

I assume that of the arduino firmware version, where do i check?
Everything is online, its only the arduino that eventually becomes disconnected
Now it works for a little while but quickly stop working
After start up I get the message “Success: Firmware flashed. MD5: B689745E140”

@chrisb the Web App popdown window on the CONNECTIVITY button is one place :slight_smile:


It rarely works, it often seems to be disconnected, previous it would work and be connected for a little bit, but lately hasnt usually worked for a while. It usually starts up with the Arduino board disconnected
I tried replacing the arduino board with one I have but that didnt seem to work.

@chrisb I logged into your device remotely and everything almost looks OK, but the RPi is giving a lot of internal USB port overcurrent warnings (not the same thing as the current indicator). Is it possible something is physically shorted out or has water damage on the RPi? I’ve only seen this happen to one other customer, and they had water damage issues.

Can you:

  • Inspect the device for short circuits, crossed wires, moisture damage, water, etc…
  • Move the Arduino to a different USB port

and let me know if that helps?

Any 2560 arduino mega board would work as a replacement?
Can I replace it with any rpi 3 or higher?
How do I login and check the USB port?
There does not appear to be any water damage or crossed wires

Yes, though I would only do this after replacing the Raspberry Pi. You may need to change the “firmware path” in the advanced settings panel if you buy a third party (non-official) Arduino board. I can provide assistance with this if you need it. I think the problem is the Raspberry Pi, though so you should not replace the Arduino yet.

:warning: No. FarmBot will only work with Raspberry Pi model 3. We will be eventually adding support for Pi 4 (in ~2 months), but current versions of FarmBot OS only work with the RPi3.

Based on the USB errors your device is having, I think the RPi is the most likely culprit.

I removed the USB camera and moved it to the middle usb block.
Can you please check again

@chrisb The errors are gone and your connectivity status is full green.

seems to be a faulty usb camera

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.