Duplicate ID error

Hello again! I have a farmbot I set up last winter that I’ve finally got rebuilt outdoors, but now I’m having connection issues:

Last shutdown reason: Failed to start child: Elixir.Farmbot.Target.Network reason: {%ArgumentError{message: “duplicated id Farmbot.Target.Network.Manager found in the supervisor specification, please explicitly pass the :id option when defining this worker/supervisor”}, [{Supervisor.Spec, :assert_unique_ids, 1, [file: ‘lib/supervisor/spec.ex’, line: 193]}, {Supervisor.Spec, :supervise, 2, [file: ‘lib/supervisor/spec.ex’, line: 176]}, {:supervisor, :init, 1, [file: ‘supervisor.erl’, line: 294]}, {:gen_server, :init_it, 2, [file: ‘gen_server.erl’, line: 365]}, {:gen_server, :init_it, 6, [file: ‘gen_server.erl’, line: 333]}, {:proc_lib, :init_p_do_apply, 3, [file: ‘proc_lib.erl’, line: 247]}]} This is likely a bug. Please copy or screenshot this error and send it to the Farmbot developers.

environment: prod

source_ref: 06966605e934e566eb4224c16792adeab28fccf8

target: rpi3


[ {Farmbot, :start, 2, [file: ‘lib/farmbot.ex’, line: 22]},

{:application_master, :start_it_old, 4, [file: ‘application_master.erl’, line: 273]}]

Get ready to configure your FarmBot!

Web App Credentials

Please download the latest FarmBot OS image through the link in Step 1 of the installing FarmBot OS documentation.

Let me know if you still experience the error with the new image.

I upgraded to the new version, and I’m no longer getting that error, but my problems haven’t stopped. I try to configure and the farmbot… never does anything. Gets through configuration fine, reboots, still on and lights flashing, but never connects. When I reboot, the configuration doesn’t remember trying to connect: it shows the first connection page, no error message. But it also saves my username and password, so it remembers something…?

That’s probably your browser saving your credentials.

Can you try to select ‘Manual Input’ when choosing your WiFi SSID?

Yes, it doesn’t help. Also, I’ve tried giving it blatantly impossible configurations (telling it to use the wrong password for my account and the wifi) and it does the same thing: no connection, no reboot, and when I manually reboot no memory of trying to configure or error code.

It sounds like the SD card could be broken (read-only). Have you tried using a different SD card?

I’m using two, neither of which had this problem with older versions of the OS.