End stops configuration


#1

Hi all,

I’ve seen some similar topics but I wanted to open a new thread in order to have everything summed up in one location.

I only set up the minimum end stops in order to make a homing sequence, which is very important especially for taking and releasing the tools.

To wire your end stops you have to plug the Signal to the NC on the switch and the ground to the C on the switch. If the “Find home” on any axis is not working try to click on “Invert end stops” and see if it works. If it’s still not working, check your wiring and if OK then change the switch in case it might be broken.

You can find where the signal and Ground pins are on your RAMPS in the following link:
https://forum.farmbot.org/uploads/default/original/1X/9a356e43a8a8fde8f0f4aca2286ca5c3bc3ea521.jpg

My problem comes when I try to set a “find home” sequence. The farmbot starts running backwards on the defined axis until it triggers the switch and then stops and sets its position to 0. If then I try to go to another position, let’s say 100 mm, the farmbot says that the movement is completed but doesn’t move since the switch is still activated. Therefore I have to deactivate the end stop, move to the desired position and then reactivate the end stop. Is there something I have to change to allow the farmbot to move even if the switch is activated? Or maybe a way to say, once you trigger the switch move 10 steps and set 0?

Thanks for your support guys!


#2

You might need to lobby to have the home sequence improved w.r.t. endstops. If you look at what CNC machines do; they move towards the endstop until it is activated. Then they stop and move away from the endstop slowly until the switch is de-activated. That point is the reference point (because it was detected while moving slowly). Then they move away from the endstop 1 or 2mm before setting the zero point. That way, you can move to and from the zero point without risking the activation of the endstop.

In any case, an activated endstop should only prevent movement in one direction (towards the endstop), the machine should be free to move away from the endstop. I’m pretty sure Farmbot does this (at least it did 18 months ago when I last looked), if you have the minimum/maximum endstop swapped then that would give the symptoms you describe.


#3

Hi @Loveny,

Thank you for your fast reply. I’ve already worked with 3D printers and know this behavior of the CNC machines, this is why I was surprised when I saw that the farmbot stopped exactly at the endstop and would not move forwards to set the 0 position.

Like 12 months ago I remember I had a colleague who also installed some endstops and the farmbot was working properly (activating the end stop, moving forward, setting 0).

I will describe you the current behaviour:

I only have the minimum end stops wired. The NC wire is connected to the GND and the C to the Signal. I honestly don’t know what else I could try.