A new error occured this morning when I tried to turn the lighting peripheral on before taking a photo and then off again. “Copyright: Copyright cant be blank.”
I’m not sure what this means?

Will take a look now thanks for letting me know @dmbgo

Any other info you can provide would be helpful. Is it an old sequence or a new one? Did you recently use the beta “shared sequence” feature?

@dmbgo Are you trying to do something like this?

To answer your questions in the order that you asked them, it is an “old” sequence (about 2 months old), I was trying the “take photo” step in the sequence, which has worked to date, but because it was dark at the time of taking the photo, I decided to see how the photo would look with the light on when the photo was taken.
I edited the existing sequence “water all plants” to add the “control peripheral” (lights) on before the “take photo” step, then “control peripheral” (lights) off afterwards. At this point, when trying to save the sequence, I received the copyright error.

My Farmbot is running Version 14.4.1

…and no I hadn’t tried using the beta “shared sequence” feature.

Yes, almost exactly like that, except the last step was “off” for the lighting peripheral.

@dmbgo It looks like your bot is doing a weed scan right now- I take it the problem went away?

To give more context: when you publish a sequence (not a regular update, but rather do a full publication to the public) it is required that you enter your name as a copyright holder when you push the publish button. The error you mentioned will pop up if you don’t enter a name for copyright holders.

We’re not able to reproduce on any of our sequences and are wondering if this was just a transient fluke while we rolled out the feature today :thinking: Please let us know if it happens again or if the problem has not yet been resolved.

No, it didn’t go away, but I’ll try again now. Perhaps it was just a transitory thing, I can always resort to the final solution of “tuning it off, then on”. :slightly_smiling_face:

No, it still is occuring:

This error only appears when I hit the “save” button.

@dmbgo can you try refreshing your browser tab? It appears you do not have the newest version of the app loaded which was deployed this morning.

I just wanted to let you know that everything worked as expected, after refreshing the tab in the browser. Thanks Rory and Rick.