Error when deleting a sequence

Hi this isn’t much of an issue for me, but I’m wondering if I am doing something incorrectly, or is this a transitory bug?
Whenever I try to delete an old sequence, the sequence is deleted and I get the message below.
If I hit refresh on my Chrome browser, the sequence is gone and all is good (until I delete another sequence, then it happens again).

"# Page Error
We can’t render this part of the page due to an unrecoverable error. Here are some things you can try:

  1. Refresh the page.
  2. Perform a “hard refresh” ( CTRL + SHIFT + R on most machines).
  3. Restart the app by clicking here. (You will be logged out of your account.)
  4. Send a report to our developer team via the FarmBot software forum. Including additional information (such as steps leading up to the error) helps us identify solutions more quickly."

Can’t reproduce this on Windows 10 with Edge beta ( based on Chrome ).
Was that ( now deleted ) sequence one that worked Ok on current FBOS ?

Yes it worked on the current OS and board. It might be me though.
Cheers
Dave

You probably found a rare bug that only appears on edgy cases. Is this error still coming up when you delete old sequences? How are fresh created sequences behaving when you delete those?
You can also check the browser console if there are any errors logged there.

@RickCarlino this could be interesting for you. Any idea what may cause this?

@dmbgo Thank you for following step number 4 on the crash page! @Ascend is most likely correct, this is probably an issue that is isolated to your account. A few questions:

  • Have you manually modified data in the API recently, either by writing custom software or by running Farmware authored by developers outside of FarmBot?
  • Can I see a screenshot of your javascript console after you reproduce the error? You can open the JS console by type CTRL + SHIFT + J. Please be sure to take the screenshot after reproducing the error.
  • Is there anything else that is “special” about your situation that I should be aware of? I just logged in to your account remotely, created an empty sequence and deleted. I did not experience any errors (Firefox on Linux).

Thanks for letting us know about this.

A bit more info from me is probably appropriate here. I was deleting old sequences because I had replaced the old Rev 1.7a farmduino with a new Farmduino V2.0a.
When I initially setup my axis lengths with the old Farmduino I was a bit gung ho with my axis measurements, so I measured them more accurately when I installed the new Farmduino and created new sequences to do most things because my crop of plants needed replanting anyway.
I have only experienced the error when deleting the old sequences that were created when using the Rev 1.7a farmduino.
To recreate the error you may need to create a sequence that is outside the axis boundaries, which may need you to change your boundaries, create the sequence, then change your boundaries again to a smaller, or different envelope.
While I appreciate everyone’s diligence following up on this issue, I think it is unlikely to reoccur in most machines.

Oh and I used to use firefox, but now I use Google @ RickCarlino

So back to my earlier question . . those sequences were not runnable on your new Farmduino v1.5-based machine ?

{edit} To the wide audience, why would Sequence content details affect the behaviour of Deleting the thing ?? ( in fact, it was the change in the Firmware Paramters that seem to be the culprit (??) )

@dmbgo I appreciate the background information, but I can’t provide help on this one until I see a screenshot of your Javascript console immediately after the error happens (ctrl + shift + J in Chrome). Something in your browser is crashing during rendering of the page while deleting and seeing the JS console will clue me in as to what that is.

1 Like

@RickCarlino Thanks for the info Rick, I’ll try to duplicate the issue, but I think I may have deleted all the culprit sequences now.

1 Like