Farm Events Never Start

I have very little luck with the calendar. It misses most events. Today it even started one on time, but completely botched the sequence. It was supposed to pick up the watering tool and water some seeds, but instead it just turned on the water and left it running. It never moved to pick up the tool. It just sat at 0,0,0 and dug a hole.

Ouch, that sounds bad. Is there anything popping up in the log, at the time your farm event should start? There should be a message like “Time for event to start at …”.

Recently I had the same issue. One day Farmbot was just staying on top of my plants and watered them … the whole night (Luckily i’m using rainwater). I assume that Farmbot was doing one of those 30min reconnections to fetch another token and stuff. Seems like it didn’t continue the sequence and didn’t turn off the water valve/pump. Still investigating this, maybe it will happen again.

1 Like

I’m not seeing anything in the logs. I don’t know if it’s related, but FB is constantly wanted to be synchronized. It stays in sync for a minute or so and then switches to SYNC NOW.

Can you show us a screenshot of your Farm-events page?
This sync-bug should already be gone, if not try to reboot the bot.

Here’s today’s farm events. Rebooting hasn’t helped, though I haven’t rebooted in the last two days.


Even without doing anything? I found out that in 5.0.2. they already updated the sync thingi, before it always went yellow even if I moved the bot manually or clicked on the update button of the “last seen” thing in the device tab…

Even without doing anything. I’d hit SYNC NOW and it would change to SYNCING, followed by IN SYNC. Then after a minute or so it would switching back to SYNC NOW. Hopefully last night’s update will make a difference.

Well, nope. That didn’t help. The update installed automatically last night and FB was rebooted. No farm events ran today.

Farm events have completely stopped since the last update. They were problematic before, but now they’re not happening at all. Did I hit a switch somewhere?

Did you press SYNC NOW after the update, and see an is synced message in the log ticker?

So. Many. Times. :slightly_smiling_face:

Is it only an issue with Regimen Farm Events? Do Farm Events that run sequences work fine? If so, it might be a device timezone issue (settable via the Device widget).

What do your logs show?

It looks like it’s happening with all farm events. I’ve only used regimens so far, but I set up a quick test sequence and it didn’t run. Nothing shows up in the ticker. Is there a way to get to the logs other than the ticker? The time zone looks correct in the device widget.

Actually… The sequence event did run. It showed up in the ticker when I reloaded the web page.


Still no luck again today. I set up another sequence to run on the calendar, but it didn’t happen either

Can you provide more information about the farm events, regimens, and sequences you are trying? How do you determine if an event runs?

What’s the best way to provide it? Screenshots?

I can tell an event runs because I’m usually standing beside it with my fingers crossed… Or I can see whether or not the ground is wet… Or I can see if anything shows up in the log ticker at the top of the web page.

Here are the events on the calendar. The events do get removed after their time has passed:

The first regimen:

The sequence from that regimen (we’re up to day 14ish, but it’s another “CARROTS @ 2760 WATER LIGHT”:


And the subsequences:



I’m still not having any success with this. Farm events are no longer starting. There’s nothing in the log to indicate that it ever tried. Calendar events are removed from the calendar once their time has passed.

Disabling automatic updates has not helped. The time zone is correct Time stamps in the log appear to be correct.

Is there any way to get any useful log data from Farmbot? Troubleshooting with no useful info is extremely frustrating. I’ve been trying to resolve this problem for weeks and it has just gone from occasionally annoying to completely broken.

We’re looking into recreating the issue with the example you have provided, but haven’t run into the issue yet. Can you share a simpler example with a Farm Event that executes a sequence? If you don’t mind, deleting the other Farm Events and rebooting may help. Farm Event log data will display in the log ticker in the web app. The only way to get more detailed logs is to use an FTDI cable connected directly to the device.

I created a sequence event which ran successfully a couple days ago, but subsequent tests didn’t run. I set up the following recurring sequence event to test this evening. Will let you know how it goes.