Farmbot cannot connect to the network after a reboot

FarmBot INFO

  • Version last seen: v10.1.4
  • Model: Express v1.0


The FarmBot is not connected to the network and is experiencing the following symptoms.

  • The Connect(Blue) LED is blinking.
  • Same symptoms when I turn the FarmBot back on.
  • No FarmBot access points appear on the WiFi network either.

A WiFi router is installed very close together, so it shouldn’t be due to a weak WiFi signal.

Does anyone know what causes FarmBot to not connect to the network and how to get it to connect?

@takesue.y Is this the first time you are seeing this error, or did the device work fine before? Did the network show up in configurator?

Additionally, when investigating network problems, it’s best to perform a “hard reflash” before proceeding.


One day, I noticed that my farmbot wasn’t working. I looked at the Connect(Blue) LED and it was blinking.

My WiFi router was in sleep mode and I noticed that this was the reason why FarmBot was not connecting to the network.

I booted up the WiFi router and looked at the WiFi access point on my phone and saw the FarmBot’s access point, so I set up the FarmBot’s network. When setting up the network, I went through the setup as normal, except that I got a screen showing the cause of the FarmBot error.

since then, I’ve had the same symptoms as I mentioned in the beginning. The FarmBot won’t connect to the network when I turn it back on, and the FarmBot access point no longer appears.

Anyway, I’ll try a hard refresh. thanks.


I did hard reflash (Re-flash FarmBot OS onto the SD Card from a desktop computer) and updated latest farmware version(v.11.0.0), but symptoms are still same.

Is there any other way to find out what’s going on?

@takesue.y Do you have any logs you can show me? If you know the private IP address of the FarmBot device, you can visit http://DEVICE_PRIVATE_IP/logger to view a log stream. Please message me these logs privately after bringing the device into isolated mode.

I took a look at your device logs remotely and it looks like one of the problems may apply:

  • Your device is too far from the access point. The Raspberry Pi 0 WiFi modem is not as sensitive as WiFi modems found in cellphones and laptops.
  • Your LAN DHCP / NAT settings may not be correct. This often happens when users perform a “daisy chain” configuration of routers (See example below). Although a daisy chain router configuration might work fine for things like email and web browsing, it will not be adequate for long lived AMQP (message broker) connections if misconfigured. We do not provide support for LAN configuration. Contact your ISP or IT department for help with LAN setup.

Can you try running your device in “isolated mode” as described in the advanced troubleshooting guide?


The problem has been solved. The cause of the problem was that the mobile communication on the WiFi router was turned off.

I connected FarmBot to another WiFi and it worked, and that’s when I realized the cause was the first WiFi router.
When I connected to the first WiFi router on my phone and browsed, I noticed that I couldn’t connect to any web pages. So I looked at the WiFi router’s screen and noticed that mobile communication was turned off.

Thanks for all the advice. I’m sorry for the trouble I’ve caused you.


Glad that your device is up and running @takesue.y.

Have a great weekend!