FarmBot Configurator Local Setup

Hi everyone,

I’m trying to setup the WebApp on my company’s server which is only accessible via the company’s network. I can log in to the WebApp and have access to every page, so more or less it is running. Now I want to connect my farmbot. The problem now is, that I dont have access to my webserver from outside the company network. So I can’t reach the configuration page when I’m connected to the Bot’s wifi. Is it possible to use the configuration page of and insert here my server’s domain? I tried it, but nothing is happening in my Webservers console.
I also still got WebSocket errors because my port 3002 is not opened yet. I have to wait till someone fixes it because I’m not the admin. But this shouldn’t be the issue.

Thanks for your help!


What is the difference between the WebApp and my farmbot? :confused:

Maybe it’s really stupid, but I thought, I had to access the configurator via the server’s IP, so my running webserver. So the difference is that the WebApp is hosted at my server and myfarmbot at Rory’s :smile:
But maybe I just got it completely wrong :no_mouth:

So you want to connect your farmbot to a network, that is not connected to the world wide Web. You have a device that runs the WebApp locally and it is accessible in the network.

So at the first startup of your Raspberry it should create a WiFi spot that you can access with your smartphone. If it doesn’t, flash the Farmbot-OS on your SD card again.
Now you can connect the farmbot by entering your server url instead of “”.

Yes, the wifi is created and I can connect to it on my phone. But connected to the FB wifi I’m outside the company network from where my WebApp is accessable. Is there any opportunity to tell the Raspi manually,which account and which server it should connect to, without the configurator? Is it set in the configs of farmbot.os?

Hello again,
I said goodbye to the company server now because it was too safe to do anything on it…
Now I’m running the WebApp locally on a normal Ubuntu system in the same network the Farmbot is plugged into. Everything works so far. But I get a WDS disconnected in the Firefox Console. And when I’m trying to connect the FB, nothing happens. The Device doesn’t connect nor is it rebooting.
Can anyone please tell me, what the WDS disconnected error is about and if it has anything to do with my connection problem! I know that you don’t have time to help all the local setuppers, but I’m lost without your help :pray::pray::pray:

Now I have no error left in the Firefox Console. The WDS disconnected error was caused by the proxy settings of the browser. But I still got no idea why the FB is not connecting. When I plug a display into it, it says:
wlan0: link becomes ready
crng init done
setting INFRA mode failed -7
eth0: hardware isn’t compatible of remote wakeup
eth0: link up, 100 Mbps, full-duplex, lpa 0xC5E1
Is there any oportunity to see where the FB fails to connect? Any logs?

Could you please please help me?? :pray:

@KarlOtta When you see the [WDS] Disconnected message, it could mean that WebPack crashed. WebPack is responsible for rendering the browser UI and associated assets.

Try running all of these in separate tabs instead of via rails api:start:

rails s -e development -b
rails r lib/log_service_runner.rb
rails r lib/resource_service_runner.rb
./node_modules/.bin/webpack-dev-server --config config/webpack.config.js
rake jobs:work
rails mqtt:start

If you see any of those processes (particualrly, ./node_modules/.bin/webpack-dev-server --config config/webpack.config.js) crash, it could be a sign of another issue.

Thanks for your answer @RickCarlino :hugs:
I think the WDS disconnected came from the proxy settings, because the error was gone after I changed them. But the farmbot is still not connecting…
I dont’t have these files in lib. there are just log_service.rb and log_service_support.rb. Did I download eventually an outdated version?
Because I don’t see errors anymore I have no idea, why the Farmbot is not connecting. I need logs of the raspi to see what is happening. Is this possible?


Did I download eventually an outdated version?

The names have recently changed, so it is possible. To update, close all running processes and try rake api:update.

It is also possible to view logs using an FTDI cable. I have also heard rumors that the latest version of nerves allows logging via the HDMI port of the Pi, but I have not tried personally.