Farmbot Express- manual control movement issues

I am new to the community as we began the install of our new Farmbot express last week on a mobile raised bed for our school. After a bit of troubleshooting network issues with our IT department, we finally have connectivity and were able to make some movement happen. Now our problems are as follows:

  • Y-axis movement is start/stop. I am using relative movements of 100 to 1000 mm. Sometimes we get fluid movement for half the prescribed distance. Sometimes we get no movement at all. The y-axis motor pulley is moving so it seems like an issue with the teeth of the belt not grabbing.

  • X-axis movement is a total no go. The x-axis motor pulleys are turning but again no teeth grab. We have tried increasing and decreasing tension on both motor pulleys but it seems like the level of torque is too much for the teeth along the belt.

  • We also have a curious thing happening where we are moving along the y-axis when suddenly the LED strip and the vacuum pump will kick on. I triple checked connections to be sure no wires were crossed there. It just seems to be happening randomly.

I know these kits are fairly new but I am hoping someone can provide some insight.

Welcome to the forum @Jjarrell, and thanks for reporting your issues.

For the first two bullet points, first ensure that the FarmBot (when powered off) can be moved by hand. Try grabbing the cross-slide and pushing and pulling it along the gantry at a slow to medium speed. It should have a small amount of resistance but not be difficult to move. When you move it, the motor will actually cause the most resistance because when it rotates it will cause a back-emf current that works against you. Again though, it shouldn’t be difficult to move.

If the cross-slide is difficult to move, most likely you need to adjust the eccentric spacers to be looser. You should have them as loose as possible without creating wobble or jiggle in the system.

Do the same for the whole gantry along the bed. It is best to grab it by the bottom wheel plates from both sides, so you’ll need someone to assist you. Again, there will be some resistance, but it should not be difficult to roll.

Once the FarmBot is checked to be moving easily, most likely your issue is your belts are not tight enough. There should be no slack in the system, otherwise the belt teeth may disengage from the pulley teeth and cause skipping and messed up movements. To tighten:

  1. Remove one belt clip
  2. Slide off the belt sleeve securing the loose end of the belt to itself. When you do this, ensure you are holding the belt such that you keep the teeth engaged.
  3. Now carefully disengage the teeth and re-engage them with a little more overlap (1-3 extra teeth). The belt may need to be fed through the clip a bit more.
  4. Slide the belt sleeve back on to secure the belt in its new position.
  5. Reinstall the belt clip to the gantry or your raised bed in the same location as it was before. The belt should be a bit tighter now.

Thanks for reporting issue 3. We’ve experienced this as well and are looking into solutions. As mentioned in the email to the purchaser of the FarmBot (maybe you?), we were able to rush ship a small number of Express units to customers on a deadline, but with the caveat that we’re still ironing out the firmware. This, along with other reported bugs, are our top priority at the moment.

Let me know if this helps solves the movement problems. Once we get to the bottom of this I’ll update the documentation with what we’ve learned.

1 Like

Thanks Rory. We are working on troubleshooting this morning utilizing your suggestions. Good news is we got some x-axis movement! The not as good news is that we are still getting a bit of hang up and slipping of the belt on the motor pulleys. Per your advice, we added lots more tension along the belt. It helped but didn’t seem to fix the issue completely.

Now that we have some movement we are also seeing a new issue come to light. Each motor pulley slips a bit during 100mm relative movements. One slips a bit more than the other so the bot is essentially moving into a bit of an angle as it works its way down the bed. I also can’t get any relative movements beyond 100mm. 1000mm movement commands just cause the motors to slip.

We are tackling this issue today and then I will move over to adjusting those eccentric spacers to take on the y-axis movement issues.

1 Like

HI Rory,

I work with JJarrell and we just received FarmBot Express for our school. couple things we are still trying to work through:

We are struggling with connectivity on our school network. Our IT has been working diligently with us to get Farmbot connect to the school network. We think it maybe an issue with the raspberry pie. I have someone from our computer science department coming over around lunch to work on it. Do we need a password for the raspberry pie? Can you please share that information with us.

Thank you,
Emily Horne

Hi @emilyhorne and @Jjarrell

There are older posts in the forum that address networking configurations in Schools.
The current Troubleshooting section of the FarmBot on-line documentation looks pretty useful.
There’s a page in there for IT Professionals.

1 Like

@Jjarrell a little update:
On February 14 we released FBOS v9.1.1 with some firmware updates that in our testing has resolved the random peripheral activation issue. If you continue to experience this, please let us know.

One more thing you may want to look into for your x-axis movements: is the surface that the wheels are riding along smooth? I know some raised beds sometimes have big knots in them that can create large bumps as the wood dries out and changes shape, or sometimes there are just surface defects that could cause issues. If needed, use a belt sander to sand the top surfaces completely smooth.

There is also about 1cm of overlap between the gantry wheel plates and the sides of the bed to prevent the FarmBot from “walking off” the bed left or right. It is possible for large splinters or other surface defects in the bed to catch the wheel plates and cause stalling. If needed, sand these surfaces smooth as well.

I’ve updated the bed assembly docs with these tips as well.

Thanks Rory. We will take a look at that OS version. The wheels appear to be rolling smooth and we used an orbital sander on all surfaces (bed rails and sides) before we put on the sealer so I do not believe this to be the biggest issue.

We did make some headway today by tweaking the motor settings for the device, in particular the steps per MM value. It may not have completely solved our issue but it seemed to help and I hope we are on the right track.

We have been enjoying the troubleshooting and learning process. Hoping we can get everything ironed out soon so we can move onto doing some growing. I have some students chomping at the bit to design some mods as well so we hope it is a great learning tool in lots of different ways.

1 Like