Farmbot OS v 10.0 - Calibration not working?

I have installed FarmOS 10.0 and get a “Calibration Error” message when I try to Calibrate X, Y or Z. Afterward, the machine is stuck and it’s impossible to use controls or Home until I do a firmware restart.

My setup:

Farmbot: Genesis 1.5 XL
Connection: via ethernet
User status: Currently still running the noob version. Could this be the problem?

I have re-flashed the SD card and the farmduino firmware several times, restarted, etc.

There is nothing specific in the log.

Any suggestion would be gratefully received!


1 Like

What exactly is the error message saying? And what does the axis do until the error comes up?
I just tried to calibrate my Y-Axis, starting from the home position and everything went well. There might be a setting mistake, but when the firmware does not react afterwards there is probably something else going wrong.

Sounds like you are a direct customer of FarmBot, so you can also message the customer support at, they might have more options to help out. Make sure to have your order number ready for that.


Thanks for your help. To answer your questions:

  1. The error message is “Calibration Failed!”
  2. The axis doesn’t do anything

I agree that there could be a setting mistake but am not sure where to start looking…

I’m having similar issues. See the attached log for details. On clicking Calibrate X on the Device page, FarmBot fails to move and I get an error as shown. Also, rebooting from the web app no longer works (see final entries in screenshot).

I originally had an OTA update that bricked the Pi, so I downloaded and flashed a new image.


1 Like

A few more data points:

  • once it gets into this state, even basic movement commands on the control page don’t respond
  • cycling the power to reboot brings back access to basic commands
  • but trying to calibrate puts it back into non-functional mode

I have a similar problem. I just updated to 10.0 1 h ago, now my calibration / find home on y-axis fails, because it doesnt detect the end, the motor tries to move over the end forever, it dosent stop anymore. On x-axis it works.
Everything worked fine just some hours ago with 9.2.2

1 Like

@mbuchberger1967 I would check what Firmware version is on your Farmduino. The OTA update from FBOS v9.2.2 up to v10.0.0 does not automatically update ( flash ) the new firmware that comes inside v10.0.0 ; you need to do that manually from the WebApp Device page.

Thanks for your suggestion. I have flashed the firmware several times but it doesn’t help.

@mbuchberger1967 what does the little drop-down window on the device page look like for you ?

On the Device section of the WebApp, click on the “version string” adjacent to the label FARMBOT OS
and look at the Firmware* info.



BTW - Thank you for this trick. I was looking for a way to find which firmware version was loaded :wink:

@jsimmonds I got the following:
is this what ou asked for?

Yesterday i did a firmware restart and a complete reboot of the FB and then my calibration on y-axis worked. This morning after powering on I had the same problem on the z-axis, again I did a restart and then it worked.
Not sure, what my problem is… do i have a wrong combination of OS and firmware?
What should be the firmware version for my FB 1.4 Genesis with OS 10.0.0 ?