Farmbot OS will not download new firmware

I tested my machine successfully and it operated on a 3.0.8 farmbot release.
Today I switched to the latest farmbot OS ( ). The webapp connects to the bot but all motor values are empty and the controls do not respond;
I tried to press UP TO DATE in the Farmbot section under CONTROLS. The farmbot detects a new firmware ( pointing to ) and allegedly starts to download it, but it does not download; It is stuck on 0% and after a while just times out. From my understanding, since the control values are all empty, there must be a problem with the firmware but it refuses to download/update.

Any advise?

1 Like

Hey @meldajon[quote=“meldajon, post:1, topic:2103”]
The webapp connects to the bot but all motor values are empty and the controls do not respond;
This could mean that your arduino does not have any communication with raspberry anymore. You switched to the newest FarmbotOS release with the update button on the website and after that it didnt work anymore? Sounds like the firmware flash was not successful.

You can try to use the “factory reset” function in the webapp, this brings the farmbot back in the state where you can configure it via WiFi. But I assume that this won’t work, because factory reset also resets the arduino, and without a connection this probably won’t work.

Can you try to flash the 3.1.6 OS to your SD-Card with a computer? After reflashing it you should be able to get the chance to reconfigure your farmbot and your firmware will be uploaded to arduino.

Btw before you start … Is there one of the LEDs on Ramps on or flashing?

1 Like

Thanks for getting back to me so quickly;
To make it clear, I actually DID flash the 3.1.6 OS through a computer but it appears from that point although the webapp connects with the machine (I work through a PC) all the motors and their values are non-functional.

On the RAMPS there does not seem to be any light on, nor flashing. There are two LEDs on the RPI3, one flashing and one constantly ON. What do you think at this point?

I was thinking perhaps during the OS setup process, to allow the Ethernet connection (I noticed there is such option in the login page where you set the WIFI and user) do you think that could be helpful to ‘pull’ the necessary download via ethernet cable and will the RPI3 know to catch it from Ethernet instead of WIFI?

Probably not relevant, but when we went from 3.1.5 to 3.1.6, the bot stopped moving - the arduino board seems to have locked itself up, would not talk to a PC even.

To test this, connect a PC with the Arduino IDE directly to the arduino board via USB - if it does not see the board then its likely its locked up.

@kimptoc it appears you nailed the problem, I tried plugging the Arduino to the PC through USB…dead beat.
Any idea how to solve this? Does it mean the Arduino is damaged or is there any way to flash it to zero?

I tried a few things - - but no joy.

Bought a new one in the end :frowning:

Thanks it’s not an expensive part so I will purchase a new one instead, it is better than spending the time on the faulty one.

1 Like

I also had this, like described in this thread.
Still I wasnt able to find out what happened and what caused it. I used the update button on the webapp and in my case it got stuck uploading to arduino and didnt change until I tried the fix with a new upload via USB.
After a few tries it worked out and I was able to upload sketches to arduino again. This issue still didnt appear anymore so its hard to find out more :frowning:

What I did to fix the problem:
-Connect Arduino to the PC, make sure that the right Serial Port and the right Arduino Board is configured.
-Open up a new sketch
-Click upload
Now it should compile for a second as you can see in the logbar.
When you can see that it starts the upload, instantly click the Reset button on the Arduino.
If you were too late, the upload seems to get stuck and probably gets timed out. Unplugging the USB cable will instantly abort the process.
Just try a few times, its not easy to find the right moment.

Maybe there are better ways to fix this, but since I only had this once I didn’t search any further.

Thanks for getting back to me @Ascend, this whole programming field is very new to me; By SKETCH do you mean there is a specific program called SKETCH or? And in that case I assume the xx.fw is the file I would need to ‘throw’ in there correct? As I earlier explained, it seems the Arduino is not reacting when linked to the PC via USB at all, Is it possible that mine is simply dead and yours just had a firmware glitch?

A sketch is some kind of a script for arduino. I assume you are using Arduino IDE (Picture of the GUI).
Just create a new file (sketch), you dont need to touch the code at all.

Yes it could be possible that we have different issues. You can load the Board information with the option “Get Board Info”.

This function needs a connection. If you can’t get any response from the board wen have a different issue.
Could you please try this?