Farmbot rebooted for OTA update and never came back

Farmbot tried to restart for the June 3rd update and I haven’t heard from it since. There are no lights on the top but the raspberry pi has its normal status lights.
It is not showing up on the network.
I have tried power cycling but it still is dead.


1 Like


We are aware of the problem you are describing. The good news is that this problem has most likely been solved in FBOS v10.1.0. Unfortunattely, the problem will not go away until after the upgrade to 10.1.1. That is to say that users upgrading from 10.0.1 (or lower) to 10.1.0 may still hit this issue.

The only way to fix the issue is to reflash the latest FBOS version to your SD card and re-run configurator. Your device data is backed up on the server and there is no risk of data loss.

Please let us know if you have any issues during WiFi configuration.

I was able to flash the new version and get it online. However, all relative movement commands, homing, and syncing failed. After repeated power cycles and factory resets I am reverting back to 1.0.1. I’ll upgrade when 1.1.1 comes out.

Is there anythong else I should try?


@waldo I’m not sure if there are any other options available. Downgrading is not a bad idea, as it will get your bot running again quickly, but unless the device is online and running the affected version I am unable to remotely view the problem so I can’t say much about what is going on.

If you are able to leave the bot plugged in on 10.1.0, I can take a look tomorrow morning. The device must be online and running the affected version in order for me to investigate. Furthermore, the difference in features between 10.0.1 to 10.1.0 is minor so waiting for 10.1.1 is fine also. Please let me know if you wish to upgrade and I can take a look.

@waldo, @RickCarlino I’ve noticed that FBOS 10.1.0 carries a “reverted” firmware for Genesis v1.5 ==> 6.5.11.H.genesisK15-360d529a.
@waldo what hardware version and model is your FarmBot ?

I’m seeing same issues. My bot is down and I have no clue what I should be doing to get it back up, attached is a screen of my settings. I don’t think I had auto update on for a new version to have caused the issue being discussed. Any thoughts? The bot flashes between sync error, unknown.

@happyfarmer @RickCarlino I think you’ll need to manually flash the RaspBerry Pi 3 FBOS SDHC back to version 9.2.2 until the MCU firmware version regression is corrected.

1 Like

@jsimmonds thank you for the note. Hate to bother you, but can you please point me to where I can get some info? I really had not signed up for so much work :).

It seems to connect in starts and stops I wish there was a way in UI to roll things back.

Appreciate your comment . . forum members have recently been discussing how well ( or not ) the FarmBot robots are understood by visitors and new owners from around the global community.

There are many topics in this Forum that can assist you to revive your machine but there’s a prerequisite ( modest ) level of “maker” skill / tech. savvy that you need to bring with you.

[edit 0]
My apologies @happyfarmer . . I should have referred you to this portion of the recently updated Official Documentation online :slight_smile:

@jsimmonds thank you for your response and guidance :). Really appreciate it. Have a great rest of your Sunday!!

Thanks!! I did not realize the guidance was for the raspberry pi software :). I’ll give it a shot.

@happyfarmer It sounds like @jsimmonds was able to help you (Thanks, John!), but if you are still looking for answers, here is a quick list of resources:

Please let me know if you are still having issues.

NOTE FOR USERS READING THIS MESSAGE VIA SEARCH: This message was written on June 7th, 2020. It might reference old versions of FarmBot OS. At the time of writing, FBOS 10.1.1 was the latest version. New versions are released every month. Check the FBOS download page for the latest version.