Farmbot stopped working after power outlet


#1

Hi,

I am working with a Farmbot XL and most of it worked well. However, after switching the electricity off it is not working anymore. After enabling the power again the motors are powered and the Raspbery Pi is having both the green and red light on. The Farmduino panel is also having some small lights, however, the blue and green lights on the buttons are still off. Therefore it is not possible to make connection with the Farmbot. After previous power outlets everything worked always after some waiting, but this time nothing is happening… Just before the power switched off there was the error “Got idle while executing a command”. I don’t know if this is important to mention, but I never saw this error before.

I tried to turn on and off everything a couple of times, and unplugged all cables to discover where the problem was, but this did’nt worked.
Does someone have any idea what I could try to get back to work again?


#2

Can you try a re-flash of the FBOS? (MicroSD card)
On mine, with a wired network connection, when it had similar fails, the WiFi Configurator did not restart. However, using a fresh OS, the Configurator is the first thing that runs.


#3

Are those LEDs constantly on? This would mean that the OS is not booting anymore, which is usually caused when something on your SD-card goes wrong. I would recommend reflashing as Tony suggested.


#4

The red light burns solid and the green light flickers like described in the manual. I will try to install the OS again see if this helps.