FarmBot stuck trying to home on boot

Help! I got 3.1.6 installed today and I was excited about the new “home on boot” option, because sometimes it reboots mid-sequence and then my home coordinates are lost/inaccurate. But the first time it rebooted it started to “home” the Z axis and got to the stopper screw and just kept going. I don’t have encoders enabled, which is probably why it failed…

I issued an E-stop, but after I started it again it cycled back into the same sequence of trying to home the Z and running the motor until I stopped it again. I tried hitting resetting the arduino back to factory but while it gave me a warning in the log that it was trying to reset, it never successfully completed. It looks to me like the homing happens before the arduino/device page is fully active because all the toggle switches are yellow instead of red or green.

I’ve tried flashing again with 3.1.6 but get the same behavior. Any ideas on how to break out of the loop? Is there a way to ssh in or manually connect to the arduino and toggle that setting? Would it work to flash back to 3.1.5?

I’ve got it powered off until I can figure something out… Thanks for any help!

Yes, encoders or endstops must be enabled to use homing, including the home on boot feature. Assuming you haven’t increased the command timeout above the default two minutes, you can boot up your device with the RAMPS power unplugged (if you don’t wish to listen to the motors grinding) and wait six minutes for the homing of each axis to timeout. Then your bot will come online and you will be able to disable the home on boot feature. In future versions, the home on boot toggle buttons will be disabled if encoders and endstops are disabled, like the homing and calibration buttons.

I am getting the same list of commands 3.1.5 for days. I then downloaded 3.1.6 and created the image and tried again. the same command seems to be happening and I can’t connect. I have pushed the reset on the ramps card to no avail.

I will now unplug the arduino from the rpi3 and restart and see if that helps.

any suggestions.??

Thanks, @Gabriel - it’s back now; it just took longer than I was expecting. I appreciate the help!

hi @Gabriel, my bot has been stuck trying to get home for 30 mins. I flashed it twice and the motors still grinding. Any suggestions?


I am having this same issue. Tried to calibrate FB, selected the “Home on Boot” option and now every time FB boots up the x-axis travels all the way to the end and, once it reaches the end, keeps grinding. It is not timing out after 6 minutes.

I have tried:

  • Resetting Arduino
  • Reflashing OS v4.0.1 onto the Raspberry Pie.

Please help!

Did find home work properly before selecting “Home on boot”?

Settings such as “Home on boot” are currently stored on the Arduino. To clear them (if you have access to the Arduino IDE), you can flash the Arduino with this code, but you will have to reconfigure FarmBot OS afterward. We are planning to move the storage of the settings to the web app in the future.