Farmware take photo not working again

Hoi zäme,

same issues I had the other day happened today again. What I can I do?!

So in the meantime I could take pictures but from one picture to another the error appeared again. Any idea what the problem could be?

See Take photo not working


any idea @Gabriel?

I just had this problem, so I factory reset the device, then plugged the usb camera into a different usb port, and all works fine again.

I will try that when I can access the bot again, thanks. @Gabriel @RickCarlino any idea why this happens or any idea how to nail the problem down?

It could be a loose connection or an electronics issue. As others have mentioned, usually unplugging the camera and plugging it back in fixes the issue.

Also try using a different USB port :slightly_smiling_face:

It fixed it for the first time but now I do have a black picture again. I will try another port next time I am able to… would be nice if you would check the connection to the cam when selecting it in the device widget…

Hey @Gabriel I just saw that not only I have this problem, please see this Thread as well: Getting black images from Farmbot do you have an idea what the problem might be?

@Gabriel @connor any idea?

Hey guys @connor @Gabriel this MUST be a software bug!

Today I rebooted my FB and updated to 6.4.1 without doing anything physically (unplugging etc.) and tadaaaa the take photo FW worked again. Could you please investigate in this bug?! That is really annoying!


what needs to happen is USB reset. there are 2 ways to do it. reboot or replug.

If I’d guess what might be the reason of the problem I’d say it is the length of the cable.