FBOS 6.4.9/10/11 Genesis v1.4 WiFi/Ethernet not working


we just set up our FarmBot Genesis v1.4 and can’t seem to get Internet connectivity through neither WiFi nor Ethernet. We are using the latest release and tried older and beta versions as well. Same issue throughout all attempts. The WiFi we are connecting through is secured with WPA2-PSK and all passwords are correctly typed in.

We tried starting the RPI with no USBs plugged in, same result. The farmbot-xxxx AP by the RPi shows up again after a while and displays:

“FARMBOT UNEXPECTEDLY SHUT DOWN Last Shutdown reason:Network not found after 1 minute(s). possible causes of this include: 1)A typo if u manually inputted the SSID. 2) The access point is out of range 3) There is too much radio interference around Farmbot. 5) There is a hardware issue.
environment: prod
source_ref: 2c7b1a8ac22866f528198b46c175c2e82bad06ce
target: rpi3”

We connected a monitor to the RPI with nothing else plugged into it. Some messages we got include:

brcmfmac: brcmf_cfg80211_stop_ap: setting INFRA mode failed -7

This is after we’ve finished the setup.
The RPi then seems to stay on until a timeout, it shuts down fast but it says something like “Ethernet timeout”, then it reboots and offers the farmbot-xxxx AP again.

Happy for any hints towards where our Problem lies!

EDIT: We got one connection of the Farmbot to the the webapp, but no connection to the Message broker. But it doesn’t seem to work now anymore. The current Firmware is 6.4.10
EDIT2: It worked another time for approx. 30s and this time we got a connection to the Message broker as well. We can’t seem to keep it working, we couldn’t issue any commands to the FB as of yet.

1 Like

We are totally having the same problem! I’m “watching” your posts so that way we can problem solve together. Feel free to email me at alias_ortega@yahoo.com in the event that we solve the problem beforehand!

Will do, we are currently trying out locally hosting the webapp and message broker. We are suspecting that our network environment is blocking the Port 5672. Do you have the same problem and do you possibly know if for you the port 5672 is open?

Here’s a photo of the monitor attached to the RPi3. The photo shows the “error messages” of the RPi3 after configuration before shutdown. When the Pi shuts down and reboots (after 69seconds, see timestamps) it immediately offers the farmbot-xxxx AP.

We suspect an error in the FBOS most likely that the configuration is not properly saved or executed, possibly overwritten.
Hoping for any official input on this issue as we cannot use the FarmBot currently.

It is working with a 4G Hotspot. We assume our university network blocks parts of the FB traffic.

@alias.ortega can you try to confirm that for your Problem? We are using 6.4.11 currently with an iPhone Hotspot.

Not a Software/FBOS issue as i was thinking, no sign of closed ports when debugging. We can see NTP traffic and traffic to my.farm.bot with our local net.

We do have that port open, but it is still not connecting

We also, tried working with a mobile hotspot, but it did not work for us. We are still trying to problem solve.

The ultimate reason for the Farmbot not working was the unreachable NTP-server on Port 123. We could use our university’s own timeserver. Of course when using a mobile hotspot we could reach the NTP, as port 123 was blocked when using the university WiFi/Ethernet.

If you are having trouble getting it to work with a mobile hotspot, then u don’t have the same issue as us.

Are u sure the Hotspot works properly?

Hmmm, that’s good to know! I will double check with the hotspot again, maybe using a different provider!

We tried a different hotspot, but no success. We understand that it is not a network issue at this point, but something that is not allowing the FArmBot to establish a connection with the Web Browser.

Are you using FBOS 6.4.11?

Maybe the bandwidth (read: data rate of the internet connection) of the hotspot is not sufficient?

I don’t think we are having the same problem then. Maybe try using an Ethernet cable or another phone. There are also LTE->WiFi Hotspots as standalone devices.

I have the same or a similar problem with 6.4.11 and Genesis V1.3. Just mine says “TLS Error: certificate expired”

Most likely NTP as well. TLS Certificate is valid but your RPi doesn’t get the correct time. So the certificate is interpreted as expired. We had this error message before using a working NTP server, the NTP port 123 was blocked prior to that.

There is no (outbound) port blocked on my network. How can I find out the root cause? Can I point to a different NTP server?

Do you have a configurable router at hand? You could capture the farmbots traffic and filter for ntp to see if it gets responses. The problem will be inbound port filtering. We have our own NTP server in our uni so we used that. I think you could just host your own NTP server on your laptop and configure that on your farmbot.

How do I configure that on the farmbot? I have access to plenty NTP servers that work just fine in my network

I put the NTP servers in the advanced field of the ethernet configuration (yes I am using LAN). Same result - certificate expired

My Farmbot worked (on the SAME network) just fine with older versions (4.6.9 and before)

It definitively a problem with the 6.4.11 version…I just flashed back 4.6.9 and it works (connects) just fine!

…or something went wrong during the first update…the RPI updated to 6.4.11 right away (although I have “auto update OFF”…now everything is back running…strange all that

How were you able to flash a version of 4.6.9? I’d like to try this! I went on to GitHub to try and find an older version but had no success. Could you potentially share that file?