Genesis Manual Fireware Update

I accidentally updated the firmware of my genesis v1.3 FarmBot to v1.5, and now it is stuck in emergency stop, so I think I need to do a manual firmware update from my laptop straight to the Arduino board, so I have downloaded the source code from FarmBot’s GitHub. If anyone can provide any assistance it would be greatly appreciated.

Hi @Jacob_Sutton,

I don’t think manually flashing the Farmduino firmware from source is going to help, because it will get overwritten on each boot if your settings are still incorrect.

If the steps below do not help, I can remotely inspect your device.

Have you tried this instead?:

  1. Manually change the firmware dropdown to the correct version (see screenshot below)
  2. Hit the “FLASH FIRMWARE” button on the device.
  3. After flash completes, perform a power cycle of the device. You will need to unplug the device from the wall. Do not use the “reboot” button in the web app.


Please let me know if this fixes the problem, otherwise I can remotely inspect the device.


I will try this when I get to work in the morning, thank you, I had only tried to fix the problem remotely using the restart buttons. I’ll let you know how it goes.

1 Like

Thank you very much, this solution worked and now the bot is up and running again.