Genesis Z axis stall detection fails --> and a workaround

Ahhh, but you didn’t show the bottom of the list :slightly_smiling_face:

P.s. If you’re in Seattle and I’m in Melbourne, how is it that we’re “overlapping” ?

Interesting. I created 7 different moisture checking points because I wanted one for each day of the week. Then, i scheduled 7 different “check moisture” events, each happening on a different day of the week and re-occurring every week. This caused no problems (at least for a while :-))

Here is the bottom of my list

Ok - lets see what happens when i delete all my events!

Overlapping - um, I might be a bit obsessive. I do love solving a good mystery too.

Oh my goodness

This is a recent record for the amount of uptime with a 10.X release.

Mr Simmonds, can’t thank you enough for your help. Its only up 18 minutes - I’ll leave it overnight - but I’m optimistic. BTW, I don’t mind the ping-ponging. Someone will again face this issue and the trail will be valuable.


Had to help because the crash looked so familiar :slightly_smiling_face:

I like to do ad-hoc QA and capacity testing when a new release appears.
Currently on 10.1.3 the total number of Farm Events varies between about 300 on the Express models up to > 2000 on the Genesis models and probably > 2500 if you swap in a RPi3B Plus

1 Like

This looks great @jrwaters @jsimmonds thanks for all your diligent investigation. Will take a closer look tomorrow morning.

1 Like

Up all day with no problems. Odd thing is that I had less than 500 total events with a Genesis 1.5 (3 per day until December). Not sure it was the quantity but events were definitely the trigger. Thanks again all.

1 Like

That’s good to know.
Just the RPi3B power in the bot to get right and you’ll be laughing :slight_smile:

If I have time and inclination I will try to reproduce this behaviour and narrow the problem.
With > 1800 Events ( all the same single sequence ) I have no issue with a Farmduino v1,5 and a RPi3B Plus on FBOS 10.1.3 :confused:

hahaha - I ordered a replacement cable today. Wanted to try an alternate brand so I could potentially give some feedback in the future.

Yeah, I’m scratching my head about what it could be. I’m going to keep it in the back of my head and perhaps experiment as well. I always think about oddities that happened and the only thing I can recall is that I changed one of my scheduled events and the primary action defaulted to plant versus an external variable. So, the whole sequence no longer required an external variable But, it was scheduled with an external variable. Likely not the issue but these are the cases that go through my mind. Gotta sleep tonight as the work week starts at 6-ish lately :frowning:

1 Like

Yes, it needs to be definitely a “charge cable” type item ( carry > 2.5A without trying ) :slight_smile:

1 Like

@jrwaters How is your bot doing? I noticed for your farm event, you mentioned “until December”. Have you tried doing a similar farm event, but instead of ending in December, end the event sooner, such as late August or possibly September?

EDIT: A previous version of this message referenced Farm Event features that are no longer current. I apologize for any confusion.

Hey @RickCarlino

Bot is doing great. I’ll re-do the events - I wasn’t aware of the scheduling difference.


How do you set up a farm event without an ending date? If I try to delete the date preset it will appear again when clicking out of the input box (lose focus).

@Ascend :man_facepalming: Sorry! I am remembering a very old version of the FarmEvent system. That is no longer an option and I will update my previous comment.

The proper fix will be to reduce the length of the FarmEvent. Eg: if it originally ended in December, try ending in late August instead to reduce the total number of occurrences.

To reiterate, this is definitely a bug and we need to investigate a fix immediately. Sorry for any confusion my previous coment may have caused.

CC: @jrwaters

1 Like

@Jsimmonds - man, hard to find a good cable that has the right angles. I searched [fairly] extensively with no luck and I’m - as I have confessed - a bit of a completionist. I ordered an adapter from Tripp Lite (they seemed to care about the specifications) and it will be here tomorrow. Let’s see if I can get GREEN voltage.

Otherwise an uneventful week. I’m a little farm-bot-lonely. My camera is now truly calibrated but I don’t even have weeds to kill. :frowning: Perhaps I’ll enter into battle with the cucumber plants that are trying to take over . . . I have only 2 words: Tough Love

The best path to a GREEN Garden :slight_smile:

@jrwaters, after testing my fix for the WiFi level reporting today on FBOS v11.0.0-beta, I’m suspecting that the yellow RPi3 Voltage might be a software issue, so, if your bot is stable and functional right now, and you’re happy with the Farmduino 5V and the USB power cable, I’d see if that Voltage color changes after the next major FBOS version is installed.
Maybe disregard the above edit. . . “RPi3 Voltage” is just a reflection of some numbers inside the RPi3B chips and may not indicate a purely DC Voltage issue :confused:

Hi @jsimmonds

Been under the water lately. But, I ordered a 3rd party USB cable and two separate connectors but couldn’t get a good fit. So, I ordered a cable directly from FarmBot and it arrived today.

Same result. My voltage is Yellow or RED. It seem to be more often RED now :frowning: I’ll wait until the next update and see.


I’ll dig into the code and the Raspberry Pi official doco. for an explanation . . mainly because I’m curious and I also had Yellow/Amber for a short time on my own RPi3B+ but couldn’t correlate it with any recent changes or operating conditions at that time :confused: Using the Same 5VDC power pack that gave Green for a long time.

1 Like

@jsimmonds - now that 11.0 is out, my voltage is GREEN. Is that your doing?

1 Like

Not Guilty, Your Honour !

When I find out what the mechanism is behind those RPI Voltage colours, I may change that plea :wink:

My contributions involved the CPU usage and WiFi strength metrics