HELP! Farmbot sync'd but no movement


#1

Web app connected/ sync’d - no movement or errors. App time is stuck on 1:52.

After reading similar posts:

I wired the additional green power supply in the event I initially used the wrong one.
I switched the USB port connecting the arduino
I reset factory settings

Note: I am new to arduino and Raspberry bi - 100% probability I jacked something up…have no idea where to begin the debug.

Chris


#2

Update: I flashed the SD image, reset to factory settings, added Arduino LED pin 13 to peripherals (blinks green on boot). Now every move or command I send results in “Farmbot didn’t get that” including "reset


#3

Which browser are you on?
Only one device which is (at the same time) logged in the account?


#4

Please connect to https://websocketstest.com/ using the same browser you use to connect to My FarmBot. If your browser does not pass the tests, it’s not suitable to be used for controlling your FarmBot.

Their website requires browsers which support websockets.


#5

Thank you for your help. I am using an iPad and Google Crome. Syncing issues are resolved. Next issue is mov movement. Only Z responds - slight, jerky movements, a lot of clicking. Y and x are completely unresponsive. Screen shots of UI and quick video to follow. Thanks again for helping me…i am very new to adrunio and ras pie.


#6

Try our FAQ article on movement issues, and let us know where you get stuck.


#7

Hi CFX,

did you try to play around with the setting of invert motor and invert encoder?
Depending on how you connected them, it might be that the bot wants to move in one direction but the encoder
wants to “detect” in the other direction. That would then result in no movement…?


#8

Mdingena - still having issues with movement. Z can move down and about an inch up before jerking about making a grinding sound. X and Y motors give off a click when called but still zero movement. We attempted playing with inversion. I plan on testing with a multi meter tonight. could the RAMP be bad? When is the new board available…this install has been a nightmare. Please help. 312-961-8193


#9

It couks be RAMPS, it could be many things. It’s important to rule out components one by one when troubleshooting. Make sure to only change one variable between checks, and eliminate suspect components.

It would help us if you could tell us what you’ve tried so far to fix the problem.


#10

It can be indeed be the RAMPS too. In our case we were very cautious placing the RAMPS on the MEGA and not to push them to hard together to avoid breakage or shortage. (We think that our first MEGA stopped working because of it). This meant that contacts between the two boards were not well enough and no motors were driven, though the signals were sent and received by the Pi and the Arduino. The Farmduino will have solved this problem.

Greetings, Tom


#11

Perfect - when can I get the farmduino? Right now I am dead in the water.


#12

I have updated the firmware to 5.1 - Y and Z movements are timing out. Motors click but do not move. Z responds moves down without issue - up isn’t fluid however the grinding is reduced. At this point I need replacement RAMPs and or the Farmsunio board? 3k, 4 more mths and countless hours wasted…Help!

Chris Felix
312-961-8193


#13

Uploading…


#14

What’s the reason for today?My farm used to be a good sport.The two days have failed


#15

I realize that English is not your first language, but I can’t understand what your are trying to say in your last post. Can you try to state your problem more clearly?