I have 2 issues to configure X-Axis on Farmbot.
The situation, My Origine (0, 0, 0) is opposite of my tool bay. In Farm Designer Menu I choose botton-Right for Origin. The electronic Box is near the Origin (0, 0, 0)

Now I want to go to my tool bay the X-Coordinates is negative. Ok why not, By If I want do the same with “Move to location” in Farm Designer they provide only positive coordinates. And of course is not working.

I have try to put “On” in “Invert Motor” and “Invert 2nd Motor” to “Off”, but they move and stop after 1cm. Is it mandatory to put “On” for “Invert encoders” too ? The workarround I find currently is to switch X1-Cable with X2-Cable (Both motor and encoder) on farduino.

Is it normal to provide positive coordinates on farm designer if we work with negative coordinates ? It’s a setting mistake from my side ?

Thank you for your help.

Yes, if you have encoders enabled and you invert a motor, you will need to invert the encoder as well.