Issues with movement

I’m in the process of setting up a sequence to go and grab a requested tool and I’m having trouble getting my Farmbot to move so that I can mark down the coordinates and begin setting up the “grab tool” sequence.

My issue is that I can’t seem to get 100% error-free movement from my Farmbot.

I got it to finally center above the tool bay where the tool I wish to select is located. (I’m guessing it’s about 15MM - 25MM distance from having full contact and connection with the tool head.)

When I try to move the Z axis down a couple MM at a time to get the exact position I get this response from the Farmbot.

5:11 pm: TreeGrowth Movement still not completed. Your bot might be stuck.
5:11 pm: TreeGrowth Movement not complete: (30, 400, 1)
5:11 pm: TreeGrowth’s Arduino says: stopped

   this occurs somewhat frequently throughout the day as I work on it.  affecting both the Z and X axis randomly. 

Sometimes it’s the X axis where I’m only able to move it forward 100MM and then backward 100MM but if I ask it to move backward 200MM after asking it to go forward 100MM I sometimes get the “movement not complete” error.
Sometimes it will move 100MM forward on X axis then only 80MM backward with the response in bold above. It’s very sporadic and inconsistent. Leaving it very hard to replicate the issue.

Another side question ( and I’ve seen one post before pertaining to this question but it was unanswered)

I’ve been trying to edit the hardware parameters but whenever I try to change the Max speed (mm/s) to a lower value and then hit save, it saves but instead of saving the new value I had input it just goes right back to the standard 800 value.



I’m having the very similar issues, mostly with the Z axis now. I’ve tried a lot of different things, and the below setup is the closest to working but still not great:

  • Updated to 3.1.3 (this afternoon)
  • Encoders all off
  • Endstops all on
  • Jumpers on the 4 endstop and negative pins (below the encoder + - pins)
  • Allow negative on Z axis
  • turn up the motor on the Z axis
1 Like

The movement not complete error can mean that FarmBot was instructed to move negative when only positive coordinates are allowed or vice versa. The allow negatives toggle will only allow FarmBot to move to negative coordinates and not positive ones.

I would recommend disabling end-stops in the settings.

Also, we’re working on the hardware settings widget right now, and will have some updates soon that will fix some issues, clarify some of the settings, and add some new options.


Is only one axis affected?
You said it’s the x-axis, but it rather sounds like you are meaning Z-axis.
Are there any strange sounds when the motors stop?
Are both X-motors acting the same?

1 Like

Today is a new day so we shall see how things turn out! hoping for the best.

So it would be the X and Z axis mostly. I haven’t had issues with the Y axis for a full two days.
The only strange sound I hear is a slight click when I send the command. As if it is about to initialize but nothing happens.
Additionally, the X axis motors are acting at the same rate.

(i made edits to my first post to correct the X being Z mistake. Thank you for clarifying that with me, Oops!)

Ahh, that would make a great deal of sense pertaining to the “allow negatives”. I will try this. As for the end-stops. I’ve had them off for a while now.
I’m happy to hear that there will be an update with the hardware widget! Looking forward to its release.


I’ll test this out. I’ve had my encoders off, I may test having them on even though Gabriel had suggested them off, just to test the waters and see what effect it may have.

Question, [quote=“bonanzajellydog, post:2, topic:1748”]
Jumpers on the 4 endstop and negative pins (below the encoder + - pins)

If it’s not to complicated to explain.
I’m a bit confused, what do you mean jumpers?

Thanks as always for the suggestions and help!


Jumpers had to be connected like I described in this post Endstop Jumpers.
But as you can see a few posts later, Tim told that they are not neccesarily needed anymore. In my opinion you would only need them when you don’t have endstops mounted and still enabled them in the web app. But that would not make any sense :confused:

Means that you don’t need those jumpers, either use endstops and enable them in the webapp, or just disable it and its fine.

Actually I’m not really sure if this is software, or hardware related. Maybe you can figure out something :slight_smile:

1 Like

Roger dodger!

I see what jumpers are now.

Well, my Farmbot is being a super pain right now.

Can barely get any movement out of it all of a sudden.

I think it might be software related.

I noticed that sometimes when I send a move command it will say movement completed (0,0,0) even though I sent a specific command of say (400,-100,-25)
at other times I tell it to move 1000MM on the X axis and it will only move 200MM out of the total units.

At this point I’m just going to work on the tool heads for now, getting all of them to register and work but until I get my movement issue figured out I won’t be setting up tool grab sequences and other such multi-level sequences.

On a side note: I have gotten this error before during move commands.

uh oh: %FunctionClauseError{arity: 1, function: :do_parse_params, module: Farmbot.Serial.Gcode.Parser}

not sure if it might help find a solution but thought I may as well provide it.

I’ll continue to troubleshoot and report any results.