Local Web-Server Error on client PCs


#1

Hi all,
Ive gotten though many issues getting farmbot connected. Ive had to resort to setting up Farmbot with the local server as the network i run farmbot with has a proxy and this can’t be circumnavigated due to been a school.

After i run sudo docker-compose up

everything seems to load then i get the below errors

Any assistance and explanation would be great. I’m assuming I’m missing something small at 330am…

> 
> [17:15:09] Starting compilation in watch mode...
>     typescript_1   | 
>     rabbit_jobs_1  | [SKYLIGHT] [3.1.4] Unable to start, see the Skylight logs for more details
>     delayed_job_1  | [SKYLIGHT] [3.1.4] Unable to start, see the Skylight logs for more details
>     delayed_job_1  | [Worker(host:05d5041f0b5f pid:1)] Starting job worker
>     delayed_job_1  | 2019-03-01T17:15:10+0000: [Worker(host:05d5041f0b5f pid:1)] Starting job worker
>     parcel_1       | [SKYLIGHT] [3.1.4] Unable to start, see the Skylight logs for more details
>     parcel_1       | rm -rf .cache public/assets/parcel
>     parcel_1       | node_modules/parcel-bundler/bin/cli.js watch frontend/css/_index.scss frontend/css/laptop_splash.scss frontend/entry.tsx frontend/front_page/index.tsx frontend/password_reset/index.tsx frontend/tos_update/index.tsx --out-dir public/assets/parcel --public-url /assets/parcel --no-hmr --no-cache --no-source-maps
>     mqtt_1         | 2019-03-01 17:15:12.067 [info] <0.33.0> Application lager started on node rabbit@e64139784b1b
>     rabbit_jobs_1  |  Attempting to connect LogService to log_channel
>     rabbit_jobs_1  |  Attempting to connect Resources::Service to resource_channel
>     rabbit_jobs_1  | W, [2019-03-01T17:15:17.451920 #1]  WARN -- #<Bunny::Session:0x558a17133ed0 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Could not establish TCP connection to mqtt:5672: Connection refused - connect(2) for 172.18.0.6:5672
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     rabbit_jobs_1  | W, [2019-03-01T17:15:17.452497 #1]  WARN -- #<Bunny::Session:0x558a171316d0 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Could not establish TCP connection to mqtt:5672: Connection refused - connect(2) for 172.18.0.6:5672
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     mqtt_1         | 2019-03-01 17:15:18.840 [info] <0.33.0> Application mnesia started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.841 [info] <0.33.0> Application crypto started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.841 [info] <0.33.0> Application jsx started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.841 [info] <0.33.0> Application xmerl started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.841 [info] <0.33.0> Application os_mon started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.842 [info] <0.33.0> Application inets started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.842 [info] <0.33.0> Application cowlib started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.842 [info] <0.33.0> Application asn1 started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.842 [info] <0.33.0> Application public_key started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.842 [info] <0.33.0> Application ssl started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.842 [info] <0.33.0> Application ranch started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.858 [info] <0.33.0> Application cowboy started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.858 [info] <0.33.0> Application ranch_proxy_protocol started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.858 [info] <0.33.0> Application recon started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.858 [info] <0.33.0> Application rabbit_common started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.867 [info] <0.33.0> Application amqp_client started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:18.869 [info] <0.240.0> 
>     mqtt_1         |  Starting RabbitMQ 3.7.6 on Erlang 20.3.8
>     mqtt_1         |  Copyright (C) 2007-2018 Pivotal Software, Inc.
>     mqtt_1         |  Licensed under the MPL.  See http://www.rabbitmq.com/
>     mqtt_1         | 
>     mqtt_1         |   ##  ##
>     mqtt_1         |   ##  ##      RabbitMQ 3.7.6. Copyright (C) 2007-2018 Pivotal Software, Inc.
>     mqtt_1         |   ##########  Licensed under the MPL.  See http://www.rabbitmq.com/
>     mqtt_1         |   ######  ##
>     mqtt_1         |   ##########  Logs: <stdout>
>     mqtt_1         | 
>     mqtt_1         |               Starting broker...
>     mqtt_1         | 2019-03-01 17:15:18.870 [info] <0.240.0> 
>     mqtt_1         |  node           : rabbit@e64139784b1b
>     mqtt_1         |  home dir       : /var/lib/rabbitmq
>     mqtt_1         |  config file(s) : /farmbot/farmbot_rmq_config.conf
>     mqtt_1         |  cookie hash    : KmTeCcfHRrW0D+gK+vuTow==
>     mqtt_1         |  log(s)         : <stdout>
>     mqtt_1         |  database dir   : /var/lib/rabbitmq/mnesia/rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:20.181 [info] <0.287.0> Memory high watermark set to 3133 MiB (3285273804 bytes) of 7832 MiB (8213184512 bytes) total
>     mqtt_1         | 2019-03-01 17:15:20.225 [info] <0.289.0> Enabling free disk space monitoring
>     mqtt_1         | 2019-03-01 17:15:20.225 [info] <0.289.0> Disk free limit set to 50MB
>     mqtt_1         | 2019-03-01 17:15:20.237 [info] <0.292.0> FHC read buffering:  OFF
>     mqtt_1         | 2019-03-01 17:15:20.237 [info] <0.292.0> FHC write buffering: ON
>     mqtt_1         | 2019-03-01 17:15:20.237 [info] <0.291.0> Limiting to approx 1048476 file handles (943626 sockets)
>     mqtt_1         | 2019-03-01 17:15:20.240 [info] <0.240.0> Waiting for Mnesia tables for 30000 ms, 9 retries left
>     rabbit_jobs_1  |  Attempting to connect Resources::Service to resource_channel
>     rabbit_jobs_1  |  Attempting to connect LogService to log_channel
>     rabbit_jobs_1  | W, [2019-03-01T17:15:20.453356 #1]  WARN -- #<Bunny::Session:0x558a171363d8 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Could not establish TCP connection to mqtt:5672: Connection refused - connect(2) for 172.18.0.6:5672
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     rabbit_jobs_1  | W, [2019-03-01T17:15:20.453512 #1]  WARN -- #<Bunny::Session:0x558a17134970 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Could not establish TCP connection to mqtt:5672: Connection refused - connect(2) for 172.18.0.6:5672
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     mqtt_1         | 2019-03-01 17:15:20.459 [info] <0.240.0> Waiting for Mnesia tables for 30000 ms, 9 retries left
>     mqtt_1         | 2019-03-01 17:15:20.459 [info] <0.240.0> Peer discovery backend rabbit_peer_discovery_classic_config does not support registration, skipping registration.
>     mqtt_1         | 2019-03-01 17:15:20.460 [info] <0.240.0> Priority queues enabled, real BQ is rabbit_variable_queue
>     mqtt_1         | 2019-03-01 17:15:20.489 [info] <0.314.0> Starting rabbit_node_monitor
>     mqtt_1         | 2019-03-01 17:15:20.557 [info] <0.240.0> Management plugin: using rates mode 'basic'
>     mqtt_1         | 2019-03-01 17:15:20.559 [info] <0.346.0> Making sure data directory '/var/lib/rabbitmq/mnesia/rabbit@e64139784b1b/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L' for vhost '/' exists
>     mqtt_1         | 2019-03-01 17:15:20.589 [info] <0.346.0> Starting message stores for vhost '/'
>     mqtt_1         | 2019-03-01 17:15:20.590 [info] <0.350.0> Message store "628WB79CIFDYO9LJI6DKMI09L/msg_store_transient": using rabbit_msg_store_ets_index to provide index
>     mqtt_1         | 2019-03-01 17:15:20.592 [info] <0.346.0> Started message store of type transient for vhost '/'
>     mqtt_1         | 2019-03-01 17:15:20.592 [info] <0.353.0> Message store "628WB79CIFDYO9LJI6DKMI09L/msg_store_persistent": using rabbit_msg_store_ets_index to provide index
>     mqtt_1         | 2019-03-01 17:15:20.599 [info] <0.346.0> Started message store of type persistent for vhost '/'
>     mqtt_1         | 2019-03-01 17:15:20.606 [info] <0.388.0> started TCP Listener on [::]:5672
>     mqtt_1         | 2019-03-01 17:15:20.607 [info] <0.240.0> Setting up a table for connection tracking on this node: tracked_connection_on_node_rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:20.607 [info] <0.240.0> Setting up a table for per-vhost connection counting on this node: tracked_connection_per_vhost_on_node_rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:20.608 [info] <0.33.0> Application rabbit started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:20.608 [info] <0.33.0> Application rabbitmq_auth_backend_http started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:20.630 [info] <0.33.0> Application rabbitmq_auth_backend_cache started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:20.648 [info] <0.33.0> Application rabbitmq_management_agent started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:20.649 [info] <0.445.0> MQTT retained message store: rabbit_mqtt_retained_msg_store_dets
>     mqtt_1         | 2019-03-01 17:15:20.651 [info] <0.463.0> started MQTT TCP Listener on [::]:1883
>     mqtt_1         | 2019-03-01 17:15:20.651 [info] <0.33.0> Application rabbitmq_mqtt started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:20.655 [info] <0.466.0> rabbit_web_mqtt: listening for HTTP connections on undefined:15675
>     mqtt_1         | 2019-03-01 17:15:20.655 [info] <0.33.0> Application rabbitmq_web_mqtt started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:20.656 [info] <0.33.0> Application rabbitmq_web_dispatch started on node rabbit@e64139784b1b
>     mqtt_1         | 2019-03-01 17:15:20.721 [info] <0.489.0> Management plugin started. Port: 15672
>     mqtt_1         | 2019-03-01 17:15:20.721 [info] <0.595.0> Statistics database started.
>     mqtt_1         | 2019-03-01 17:15:20.722 [info] <0.33.0> Application rabbitmq_management started on node rabbit@e64139784b1b
>     mqtt_1         |  completed with 7 plugins.
>     mqtt_1         | 2019-03-01 17:15:21.028 [info] <0.5.0> Server startup complete; 7 plugins started.
>     mqtt_1         |  * rabbitmq_management
>     mqtt_1         |  * rabbitmq_web_dispatch
>     mqtt_1         |  * rabbitmq_web_mqtt
>     mqtt_1         |  * rabbitmq_mqtt
>     mqtt_1         |  * rabbitmq_management_agent
>     mqtt_1         |  * rabbitmq_auth_backend_cache
>     mqtt_1         |  * rabbitmq_auth_backend_http
>     rabbit_jobs_1  |  Attempting to connect Resources::Service to resource_channel
>     rabbit_jobs_1  |  Attempting to connect LogService to log_channel
>     mqtt_1         | 2019-03-01 17:15:23.455 [info] <0.605.0> accepting AMQP connection <0.605.0> (172.18.0.7:60020 -> 172.18.0.6:5672)
>     mqtt_1         | 2019-03-01 17:15:23.455 [info] <0.608.0> accepting AMQP connection <0.608.0> (172.18.0.7:60022 -> 172.18.0.6:5672)
>     rabbit_jobs_1  | E, [2019-03-01T17:15:23.458991 #1] ERROR -- #<Bunny::Session:0x558a17141760 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Authentication with RabbitMQ failed: 403 ACCESS_REFUSED - Login was refused using authentication mechanism PLAIN. For details see the broker logfile.
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     rabbit_jobs_1  | E, [2019-03-01T17:15:23.459315 #1] ERROR -- #<Bunny::Session:0x558a1714b7d8 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Authentication with RabbitMQ failed: 403 ACCESS_REFUSED - Login was refused using authentication mechanism PLAIN. For details see the broker logfile.
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     mqtt_1         | 2019-03-01 17:15:23.458 [error] <0.608.0> Error on AMQP connection <0.608.0> (172.18.0.7:60022 -> 172.18.0.6:5672, state: starting):
>     mqtt_1         | PLAIN login refused: rabbit_auth_backend_cache failed authenticating admin: {failed_connect,
>     mqtt_1         |                                                         [{to_address,
>     mqtt_1         |                                                           {"localhost",3000}},
>     mqtt_1         |                                                          {inet,
>     mqtt_1         |                                                           [inet],
>     mqtt_1         |                                                           econnrefused}]}
>     mqtt_1         | 
>     mqtt_1         | 2019-03-01 17:15:23.458 [error] <0.605.0> Error on AMQP connection <0.605.0> (172.18.0.7:60020 -> 172.18.0.6:5672, state: starting):
>     mqtt_1         | PLAIN login refused: rabbit_auth_backend_cache failed authenticating admin: {failed_connect,
>     mqtt_1         |                                                         [{to_address,
>     mqtt_1         |                                                           {"localhost",3000}},
>     mqtt_1         |                                                          {inet,
>     mqtt_1         |                                                           [inet],
>     mqtt_1         |                                                           econnrefused}]}
>     mqtt_1         | 
>     rabbit_jobs_1  |  Attempting to connect Resources::Service to resource_channel
>     mqtt_1         | 2019-03-01 17:15:26.459 [info] <0.608.0> closing AMQP connection <0.608.0> (172.18.0.7:60022 -> 172.18.0.6:5672)
>     rabbit_jobs_1  |  Attempting to connect LogService to log_channel
>     mqtt_1         | 2019-03-01 17:15:26.460 [info] <0.605.0> closing AMQP connection <0.605.0> (172.18.0.7:60020 -> 172.18.0.6:5672)
>     mqtt_1         | 2019-03-01 17:15:26.461 [info] <0.615.0> accepting AMQP connection <0.615.0> (172.18.0.7:60030 -> 172.18.0.6:5672)
>     mqtt_1         | 2019-03-01 17:15:26.462 [info] <0.618.0> accepting AMQP connection <0.618.0> (172.18.0.7:60032 -> 172.18.0.6:5672)
>     rabbit_jobs_1  | E, [2019-03-01T17:15:26.465510 #1] ERROR -- #<Bunny::Session:0x558a17160408 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Authentication with RabbitMQ failed: 403 ACCESS_REFUSED - Login was refused using authentication mechanism PLAIN. For details see the broker logfile.
>     mqtt_1         | 2019-03-01 17:15:26.465 [error] <0.618.0> Error on AMQP connection <0.618.0> (172.18.0.7:60032 -> 172.18.0.6:5672, state: starting):
>     mqtt_1         | PLAIN login refused: rabbit_auth_backend_cache failed authenticating admin: {failed_connect,
>     mqtt_1         |                                                         [{to_address,
>     mqtt_1         |                                                           {"localhost",3000}},
>     mqtt_1         |                                                          {inet,
>     mqtt_1         |                                                           [inet],
>     mqtt_1         |                                                           econnrefused}]}
>     mqtt_1         | 
>     mqtt_1         | 2019-03-01 17:15:26.465 [error] <0.615.0> Error on AMQP connection <0.615.0> (172.18.0.7:60030 -> 172.18.0.6:5672, state: starting):
>     mqtt_1         | PLAIN login refused: rabbit_auth_backend_cache failed authenticating admin: {failed_connect,
>     mqtt_1         |                                                         [{to_address,
>     mqtt_1         |                                                           {"localhost",3000}},
>     mqtt_1         |                                                          {inet,
>     mqtt_1         |                                                           [inet],
>     mqtt_1         |                                                           econnrefused}]}
>     mqtt_1         | 
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     rabbit_jobs_1  | E, [2019-03-01T17:15:26.468234 #1] ERROR -- #<Bunny::Session:0x558a17176cf8 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Authentication with RabbitMQ failed: 403 ACCESS_REFUSED - Login was refused using authentication mechanism PLAIN. For details see the broker logfile.
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     mqtt_1         | 2019-03-01 17:15:29.466 [info] <0.618.0> closing AMQP connection <0.618.0> (172.18.0.7:60032 -> 172.18.0.6:5672)
>     mqtt_1         | 2019-03-01 17:15:29.466 [info] <0.615.0> closing AMQP connection <0.615.0> (172.18.0.7:60030 -> 172.18.0.6:5672)
>     rabbit_jobs_1  |  Attempting to connect Resources::Service to resource_channel
>     rabbit_jobs_1  |  Attempting to connect LogService to log_channel
>     mqtt_1         | 2019-03-01 17:15:29.471 [info] <0.625.0> accepting AMQP connection <0.625.0> (172.18.0.7:60034 -> 172.18.0.6:5672)
>     mqtt_1         | 2019-03-01 17:15:29.472 [info] <0.628.0> accepting AMQP connection <0.628.0> (172.18.0.7:60036 -> 172.18.0.6:5672)
>     mqtt_1         | 2019-03-01 17:15:29.474 [error] <0.625.0> Error on AMQP connection <0.625.0> (172.18.0.7:60034 -> 172.18.0.6:5672, state: starting):
>     mqtt_1         | PLAIN login refused: rabbit_auth_backend_cache failed authenticating admin: {failed_connect,
>     mqtt_1         |                                                         [{to_address,
>     mqtt_1         |                                                           {"localhost",3000}},
>     mqtt_1         |                                                          {inet,
>     mqtt_1         |                                                           [inet],
>     mqtt_1         |                                                           econnrefused}]}
>     mqtt_1         | 
>     rabbit_jobs_1  | E, [2019-03-01T17:15:29.476232 #1] ERROR -- #<Bunny::Session:0x558a17181c98 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Authentication with RabbitMQ failed: 403 ACCESS_REFUSED - Login was refused using authentication mechanism PLAIN. For details see the broker logfile.
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     mqtt_1         | 2019-03-01 17:15:29.477 [error] <0.628.0> Error on AMQP connection <0.628.0> (172.18.0.7:60036 -> 172.18.0.6:5672, state: starting):
>     mqtt_1         | PLAIN login refused: rabbit_auth_backend_cache failed authenticating admin: {failed_connect,
>     mqtt_1         |                                                         [{to_address,
>     mqtt_1         |                                                           {"localhost",3000}},
>     mqtt_1         |                                                          {inet,
>     mqtt_1         |                                                           [inet],
>     mqtt_1         |                                                           econnrefused}]}
>     mqtt_1         | 
>     rabbit_jobs_1  | E, [2019-03-01T17:15:29.478135 #1] ERROR -- #<Bunny::Session:0x558a17187648 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Authentication with RabbitMQ failed: 403 ACCESS_REFUSED - Login was refused using authentication mechanism PLAIN. For details see the broker logfile.
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     mqtt_1         | 2019-03-01 17:15:32.476 [info] <0.625.0> closing AMQP connection <0.625.0> (172.18.0.7:60034 -> 172.18.0.6:5672)
>     rabbit_jobs_1  |  Attempting to connect Resources::Service to resource_channel
>     rabbit_jobs_1  |  Attempting to connect LogService to log_channel
>     mqtt_1         | 2019-03-01 17:15:32.479 [info] <0.628.0> closing AMQP connection <0.628.0> (172.18.0.7:60036 -> 172.18.0.6:5672)
>     mqtt_1         | 2019-03-01 17:15:32.479 [info] <0.634.0> accepting AMQP connection <0.634.0> (172.18.0.7:60038 -> 172.18.0.6:5672)
>     mqtt_1         | 2019-03-01 17:15:32.483 [info] <0.638.0> accepting AMQP connection <0.638.0> (172.18.0.7:60040 -> 172.18.0.6:5672)
>     rabbit_jobs_1  | E, [2019-03-01T17:15:32.486770 #1] ERROR -- #<Bunny::Session:0x558a1719c8e0 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Authentication with RabbitMQ failed: 403 ACCESS_REFUSED - Login was refused using authentication mechanism PLAIN. For details see the broker logfile.
>     mqtt_1         | 2019-03-01 17:15:32.486 [error] <0.638.0> Error on AMQP connection <0.638.0> (172.18.0.7:60040 -> 172.18.0.6:5672, state: starting):
>     mqtt_1         | PLAIN login refused: rabbit_auth_backend_cache failed authenticating admin: {failed_connect,
>     mqtt_1         |                                                         [{to_address,
>     mqtt_1         |                                                           {"localhost",3000}},
>     mqtt_1         |                                                          {inet,
>     mqtt_1         |                                                           [inet],
>     mqtt_1         |                                                           econnrefused}]}
>     mqtt_1         | 
>     mqtt_1         | 2019-03-01 17:15:32.486 [error] <0.634.0> Error on AMQP connection <0.634.0> (172.18.0.7:60038 -> 172.18.0.6:5672, state: starting):
>     mqtt_1         | PLAIN login refused: rabbit_auth_backend_cache failed authenticating admin: {failed_connect,
>     mqtt_1         |                                                         [{to_address,
>     mqtt_1         |                                                           {"localhost",3000}},
>     mqtt_1         |                                                          {inet,
>     mqtt_1         |                                                           [inet],
>     mqtt_1         |                                                           econnrefused}]}
>     mqtt_1         | 
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     rabbit_jobs_1  | E, [2019-03-01T17:15:32.489766 #1] ERROR -- #<Bunny::Session:0x558a171b2c58 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Authentication with RabbitMQ failed: 403 ACCESS_REFUSED - Login was refused using authentication mechanism PLAIN. For details see the broker logfile.
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     mqtt_1         | 2019-03-01 17:15:35.487 [info] <0.634.0> closing AMQP connection <0.634.0> (172.18.0.7:60038 -> 172.18.0.6:5672)
>     mqtt_1         | 2019-03-01 17:15:35.487 [info] <0.638.0> closing AMQP connection <0.638.0> (172.18.0.7:60040 -> 172.18.0.6:5672)
>     rabbit_jobs_1  |  Attempting to connect Resources::Service to resource_channel
>     rabbit_jobs_1  |  Attempting to connect LogService to log_channel
>     mqtt_1         | 2019-03-01 17:15:35.491 [info] <0.645.0> accepting AMQP connection <0.645.0> (172.18.0.7:60042 -> 172.18.0.6:5672)
>     rabbit_jobs_1  | E, [2019-03-01T17:15:35.497391 #1] ERROR -- #<Bunny::Session:0x558a171d3ca0 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Authentication with RabbitMQ failed: 403 ACCESS_REFUSED - Login was refused using authentication mechanism PLAIN. For details see the broker logfile.
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     mqtt_1         | 2019-03-01 17:15:35.495 [error] <0.645.0> Error on AMQP connection <0.645.0> (172.18.0.7:60042 -> 172.18.0.6:5672, state: starting):
>     mqtt_1         | PLAIN login refused: rabbit_auth_backend_cache failed authenticating admin: {failed_connect,
>     mqtt_1         |                                                         [{to_address,
>     mqtt_1         |                                                           {"localhost",3000}},
>     mqtt_1         |                                                          {inet,
>     mqtt_1         |                                                           [inet],
>     mqtt_1         |                                                           econnrefused}]}
>     mqtt_1         | 
>     mqtt_1         | 2019-03-01 17:15:35.497 [info] <0.649.0> accepting AMQP connection <0.649.0> (172.18.0.7:60044 -> 172.18.0.6:5672)
>     rabbit_jobs_1  | E, [2019-03-01T17:15:35.500921 #1] ERROR -- #<Bunny::Session:0x558a171d1a68 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Authentication with RabbitMQ failed: 403 ACCESS_REFUSED - Login was refused using authentication mechanism PLAIN. For details see the broker logfile.
>     mqtt_1         | 2019-03-01 17:15:35.500 [error] <0.649.0> Error on AMQP connection <0.649.0> (172.18.0.7:60044 -> 172.18.0.6:5672, state: starting):
>     mqtt_1         | PLAIN login refused: rabbit_auth_backend_cache failed authenticating admin: {failed_connect,
>     mqtt_1         |                                                         [{to_address,
>     mqtt_1         |                                                           {"localhost",3000}},
>     mqtt_1         |                                                          {inet,
>     mqtt_1         |                                                           [inet],
>     mqtt_1         |                                                           econnrefused}]}
>     mqtt_1         | 
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     mqtt_1         | 2019-03-01 17:15:38.496 [info] <0.645.0> closing AMQP connection <0.645.0> (172.18.0.7:60042 -> 172.18.0.6:5672)
>     mqtt_1         | 2019-03-01 17:15:38.502 [info] <0.649.0> closing AMQP connection <0.649.0> (172.18.0.7:60044 -> 172.18.0.6:5672)
>     rabbit_jobs_1  |  Attempting to connect Resources::Service to resource_channel
>     rabbit_jobs_1  |  Attempting to connect LogService to log_channel
>     mqtt_1         | 2019-03-01 17:15:38.506 [info] <0.655.0> accepting AMQP connection <0.655.0> (172.18.0.7:60046 -> 172.18.0.6:5672)
>     mqtt_1         | 2019-03-01 17:15:38.506 [info] <0.658.0> accepting AMQP connection <0.658.0> (172.18.0.7:60048 -> 172.18.0.6:5672)
>     rabbit_jobs_1  | E, [2019-03-01T17:15:38.509679 #1] ERROR -- #<Bunny::Session:0x558a171e9168 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Authentication with RabbitMQ failed: 403 ACCESS_REFUSED - Login was refused using authentication mechanism PLAIN. For details see the broker logfile.
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     mqtt_1         | 2019-03-01 17:15:38.510 [error] <0.658.0> Error on AMQP connection <0.658.0> (172.18.0.7:60048 -> 172.18.0.6:5672, state: starting):
>     mqtt_1         | PLAIN login refused: rabbit_auth_backend_cache failed authenticating admin: {failed_connect,
>     mqtt_1         |                                                         [{to_address,
>     mqtt_1         |                                                           {"localhost",3000}},
>     mqtt_1         |                                                          {inet,
>     mqtt_1         |                                                           [inet],
>     mqtt_1         |                                                           econnrefused}]}
>     mqtt_1         | 
>     rabbit_jobs_1  | E, [2019-03-01T17:15:38.525647 #1] ERROR -- #<Bunny::Session:0x558a171eae50 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Authentication with RabbitMQ failed: 403 ACCESS_REFUSED - Login was refused using authentication mechanism PLAIN. For details see the broker logfile.
>     rabbit_jobs_1  | Connecting to broker in 3 seconds.
>     mqtt_1         | 2019-03-01 17:15:38.526 [error] <0.655.0> Error on AMQP connection <0.655.0> (172.18.0.7:60046 -> 172.18.0.6:5672, state: starting):
>     mqtt_1         | PLAIN login refused: rabbit_auth_backend_cache failed authenticating admin: {failed_connect,

#2

Rebuilt the server found the issue was I had a separate MQTT server running now the web app installs and i can browse to it locally and it seems like farmbot also connects

However im now getting a broker error the farmbot webapp check screen is green for Farmbot --> WebApp–> Browwser

but Yellow for Farmbot–>MessageBroker --> Browser

Any suggestions. I am running this server offline due to a proxy running which means I cannot get farmbot to connect to the proxy prompt to insert username and password

Ive already setup Farmbot to search for our local NTP server for time still not getting a responce from the broker

[06:42:12] Starting compilation in watch mode…
typescript_1 |
mqtt_1 | 2019-03-08 06:42:13.785 [info] <0.33.0> Application lager started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.733 [info] <0.33.0> Application mnesia started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.733 [info] <0.33.0> Application crypto started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.734 [info] <0.33.0> Application jsx started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.734 [info] <0.33.0> Application xmerl started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.735 [info] <0.33.0> Application os_mon started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.735 [info] <0.33.0> Application inets started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.736 [info] <0.33.0> Application cowlib started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.736 [info] <0.33.0> Application asn1 started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.736 [info] <0.33.0> Application public_key started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.737 [info] <0.33.0> Application ssl started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.737 [info] <0.33.0> Application ranch started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.743 [info] <0.33.0> Application cowboy started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.743 [info] <0.33.0> Application ranch_proxy_protocol started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.743 [info] <0.33.0> Application recon started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.743 [info] <0.33.0> Application rabbit_common started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.747 [info] <0.33.0> Application amqp_client started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:17.748 [info] <0.267.0>
mqtt_1 | Starting RabbitMQ 3.7.6 on Erlang 20.3.8
mqtt_1 | Copyright © 2007-2018 Pivotal Software, Inc.
mqtt_1 | Licensed under the MPL. See http://www.rabbitmq.com/
mqtt_1 |
mqtt_1 | ## ##
mqtt_1 | ## ## RabbitMQ 3.7.6. Copyright © 2007-2018 Pivotal Software, Inc.
mqtt_1 | ########## Licensed under the MPL. See http://www.rabbitmq.com/
mqtt_1 | ###### ##
mqtt_1 | ########## Logs: <stdout>
mqtt_1 |
mqtt_1 | Starting broker…
mqtt_1 | 2019-03-08 06:42:17.748 [info] <0.267.0>
mqtt_1 | node : rabbit@ef8713d44f9d
mqtt_1 | home dir : /var/lib/rabbitmq
mqtt_1 | config file(s) : /farmbot/farmbot_rmq_config.conf
mqtt_1 | cookie hash : AXxyL3wJTC+R5NwiHZKiPA==
mqtt_1 | log(s) : <stdout>
mqtt_1 | database dir : /var/lib/rabbitmq/mnesia/rabbit@ef8713d44f9d
web_1 | => Booting Thin
web_1 | => Rails 5.2.2 application starting in production on http://0.0.0.0:3000
web_1 | => Run rails server -h for more startup options
mqtt_1 | 2019-03-08 06:42:18.764 [info] <0.273.0> Memory high watermark set to 3133 MiB (3285467136 bytes) of 7833 MiB (8213667840 bytes) total
mqtt_1 | 2019-03-08 06:42:18.768 [info] <0.275.0> Enabling free disk space monitoring
mqtt_1 | 2019-03-08 06:42:18.768 [info] <0.275.0> Disk free limit set to 50MB
mqtt_1 | 2019-03-08 06:42:18.785 [info] <0.277.0> Limiting to approx 1048476 file handles (943626 sockets)
mqtt_1 | 2019-03-08 06:42:18.785 [info] <0.278.0> FHC read buffering: OFF
mqtt_1 | 2019-03-08 06:42:18.785 [info] <0.278.0> FHC write buffering: ON
mqtt_1 | 2019-03-08 06:42:18.804 [info] <0.267.0> Waiting for Mnesia tables for 30000 ms, 9 retries left
mqtt_1 | 2019-03-08 06:42:19.092 [info] <0.267.0> Waiting for Mnesia tables for 30000 ms, 9 retries left
mqtt_1 | 2019-03-08 06:42:19.092 [info] <0.267.0> Peer discovery backend rabbit_peer_discovery_classic_config does not support registration, skipping registration.
mqtt_1 | 2019-03-08 06:42:19.093 [info] <0.267.0> Priority queues enabled, real BQ is rabbit_variable_queue
mqtt_1 | 2019-03-08 06:42:19.183 [info] <0.300.0> Starting rabbit_node_monitor
mqtt_1 | 2019-03-08 06:42:19.224 [info] <0.267.0> Management plugin: using rates mode ‘basic’
mqtt_1 | 2019-03-08 06:42:19.225 [info] <0.332.0> Making sure data directory ‘/var/lib/rabbitmq/mnesia/rabbit@ef8713d44f9d/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L’ for vhost ‘/’ exists
mqtt_1 | 2019-03-08 06:42:19.326 [info] <0.332.0> Starting message stores for vhost ‘/’
mqtt_1 | 2019-03-08 06:42:19.326 [info] <0.336.0> Message store “628WB79CIFDYO9LJI6DKMI09L/msg_store_transient”: using rabbit_msg_store_ets_index to provide index
mqtt_1 | 2019-03-08 06:42:19.335 [info] <0.332.0> Started message store of type transient for vhost ‘/’
mqtt_1 | 2019-03-08 06:42:19.335 [info] <0.339.0> Message store “628WB79CIFDYO9LJI6DKMI09L/msg_store_persistent”: using rabbit_msg_store_ets_index to provide index
mqtt_1 | 2019-03-08 06:42:19.337 [info] <0.332.0> Started message store of type persistent for vhost ‘/’
mqtt_1 | 2019-03-08 06:42:19.481 [info] <0.380.0> started TCP Listener on [::]:5672
mqtt_1 | 2019-03-08 06:42:19.482 [info] <0.267.0> Setting up a table for connection tracking on this node: tracked_connection_on_node_rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:19.482 [info] <0.267.0> Setting up a table for per-vhost connection counting on this node: tracked_connection_per_vhost_on_node_rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:19.483 [info] <0.33.0> Application rabbit started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:19.483 [info] <0.33.0> Application rabbitmq_auth_backend_http started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:19.489 [info] <0.33.0> Application rabbitmq_auth_backend_cache started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:19.502 [info] <0.33.0> Application rabbitmq_management_agent started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:19.503 [info] <0.437.0> MQTT retained message store: rabbit_mqtt_retained_msg_store_dets
mqtt_1 | 2019-03-08 06:42:19.504 [info] <0.455.0> started MQTT TCP Listener on [::]:1883
mqtt_1 | 2019-03-08 06:42:19.505 [info] <0.33.0> Application rabbitmq_mqtt started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:19.506 [info] <0.458.0> rabbit_web_mqtt: listening for HTTP connections on undefined:15675
mqtt_1 | 2019-03-08 06:42:19.507 [info] <0.33.0> Application rabbitmq_web_mqtt started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:19.507 [info] <0.33.0> Application rabbitmq_web_dispatch started on node rabbit@ef8713d44f9d
mqtt_1 | 2019-03-08 06:42:19.606 [info] <0.481.0> Management plugin started. Port: 15672
mqtt_1 | 2019-03-08 06:42:19.606 [info] <0.587.0> Statistics database started.
mqtt_1 | 2019-03-08 06:42:19.608 [info] <0.33.0> Application rabbitmq_management started on node rabbit@ef8713d44f9d
web_1 | [SKYLIGHT] [3.1.4] Unable to start, see the Skylight logs for more details
rabbit_jobs_1 | [SKYLIGHT] [3.1.4] Unable to start, see the Skylight logs for more details
log_digests_1 | [SKYLIGHT] [3.1.4] Unable to start, see the Skylight logs for more details
delayed_job_1 | [SKYLIGHT] [3.1.4] Unable to start, see the Skylight logs for more details
parcel_1 | [SKYLIGHT] [3.1.4] Unable to start, see the Skylight logs for more details
log_digests_1 | Running log digest loop…
delayed_job_1 | [Worker(host:16fbf8d44019 pid:1)] Starting job worker
delayed_job_1 | 2019-03-08T06:42:20+0000: [Worker(host:16fbf8d44019 pid:1)] Starting job worker
mqtt_1 | completed with 7 plugins.
mqtt_1 | 2019-03-08 06:42:20.464 [info] <0.5.0> Server startup complete; 7 plugins started.
mqtt_1 | * rabbitmq_management
mqtt_1 | * rabbitmq_web_dispatch
mqtt_1 | * rabbitmq_web_mqtt
mqtt_1 | * rabbitmq_mqtt
mqtt_1 | * rabbitmq_management_agent
mqtt_1 | * rabbitmq_auth_backend_cache
mqtt_1 | * rabbitmq_auth_backend_http
parcel_1 | rm -rf .cache public/assets/parcel
parcel_1 | node_modules/parcel-bundler/bin/cli.js watch frontend/css/_index.scss frontend/css/laptop_splash.scss frontend/entry.tsx frontend/front_page/index.tsx frontend/password_reset/index.tsx frontend/tos_update/index.tsx --out-dir public/assets/parcel --public-url /assets/parcel --no-hmr --no-cache --no-source-maps
mqtt_1 | 2019-03-08 06:42:22.232 [info] <0.597.0> accepting AMQP connection <0.597.0> (10.67.108.159:39259 -> 172.18.0.6:5672)
mqtt_1 | 2019-03-08 06:42:22.253 [error] <0.597.0> Error on AMQP connection <0.597.0> (10.67.108.159:39259 -> 172.18.0.6:5672, state: starting):
mqtt_1 | PLAIN login refused: rabbit_auth_backend_cache failed authenticating device_4: socket_closed_remotely
mqtt_1 |
mqtt_1 | 2019-03-08 06:42:22.254 [info] <0.597.0> closing AMQP connection <0.597.0> (10.67.108.159:39259 -> 172.18.0.6:5672)
web_1 | Thin web server (v1.7.2 codename Bachmanity)
web_1 | Maximum connections set to 1024
web_1 | Listening on 0.0.0.0:3000, CTRL+C to stop
mqtt_1 | 2019-03-08 06:42:27.283 [info] <0.605.0> accepting AMQP connection <0.605.0> (10.67.108.159:34655 -> 172.18.0.6:5672)
web_1 | Started POST “/api/rmq/user” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#user as JSON
web_1 | Parameters: {“username”=>“device_4”, “password”=>"[FILTERED]"}
web_1 | Completed 200 OK in 148ms (Views: 13.0ms | ActiveRecord: 61.3ms)
web_1 | Started POST “/api/rmq/vhost” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#vhost as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “ip”=>"::ffff:10.67.108.159"}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
mqtt_1 | 2019-03-08 06:42:27.486 [info] <0.605.0> connection <0.605.0> (10.67.108.159:34655 -> 172.18.0.6:5672): user ‘device_4’ authenticated and granted access to vhost ‘/’
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“queue”, “name”=>“device_4_from_clients”, “permission”=>“configure”}
web_1 | Completed 200 OK in 1ms (Views: 0.4ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“queue”, “name”=>“device_4_from_clients”, “permission”=>“read”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“queue”, “name”=>“device_4_from_clients”, “permission”=>“write”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“exchange”, “name”=>“amq.topic”, “permission”=>“read”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/topic” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#topic as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“topic”, “name”=>“amq.topic”, “permission”=>“read”, “routing_key”=>“bot.device_4.from_clients”, “variable_map.username”=>“device_4”, “variable_map.vhost”=>"/"}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“queue”, “name”=>“device_4_auto_sync”, “permission”=>“configure”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“queue”, “name”=>“device_4_auto_sync”, “permission”=>“write”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/topic” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#topic as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“topic”, “name”=>“amq.topic”, “permission”=>“read”, “routing_key”=>“bot.device_4.sync.#”, “variable_map.username”=>“device_4”, “variable_map.vhost”=>"/"}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“queue”, “name”=>“device_4_nerves_hub”, “permission”=>“configure”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“queue”, “name”=>“device_4_nerves_hub”, “permission”=>“write”}
web_1 | Completed 200 OK in 1ms (Views: 0.6ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/topic” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#topic as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“topic”, “name”=>“amq.topic”, “permission”=>“read”, “routing_key”=>“bot.device_4.nerves_hub”, “variable_map.username”=>“device_4”, “variable_map.vhost”=>"/"}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“queue”, “name”=>“device_4_auto_sync”, “permission”=>“read”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“queue”, “name”=>“device_4_nerves_hub”, “permission”=>“read”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“exchange”, “name”=>“amq.topic”, “permission”=>“write”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/topic” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#topic as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“topic”, “name”=>“amq.topic”, “permission”=>“write”, “routing_key”=>“bot.device_4.status”, “variable_map.username”=>“device_4”, “variable_map.vhost”=>"/"}
web_1 | Completed 200 OK in 19ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/topic” for 172.18.0.1 at 2019-03-08 06:42:27 +0000
web_1 | Processing by Api::RmqUtilsController#topic as JSON
web_1 | Parameters: {“username”=>“device_4”, “vhost”=>"/", “resource”=>“topic”, “name”=>“amq.topic”, “permission”=>“write”, “routing_key”=>“bot.device_4.logs”, “variable_map.username”=>“device_4”, “variable_map.vhost”=>"/"}
web_1 | Completed 200 OK in 1ms (Views: 0.6ms | ActiveRecord: 0.0ms)
rabbit_jobs_1 | Attempting to connect LogService to log_channel
rabbit_jobs_1 | Attempting to connect Resources::Service to resource_channel
mqtt_1 | 2019-03-08 06:42:28.621 [info] <0.646.0> accepting AMQP connection <0.646.0> (172.18.0.9:47418 -> 172.18.0.6:5672)
mqtt_1 | 2019-03-08 06:42:28.623 [info] <0.649.0> accepting AMQP connection <0.649.0> (172.18.0.9:47420 -> 172.18.0.6:5672)
web_1 | Started POST “/api/rmq/user” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#user as JSON
web_1 | Parameters: {“username”=>“admin”, “password”=>"[FILTERED]"}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/user” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#user as JSON
web_1 | Parameters: {“username”=>“admin”, “password”=>"[FILTERED]"}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
rabbit_jobs_1 | I, [2019-03-08T06:42:28.640317 #1] INFO – #<Bunny::Session:0x5625c9b40060 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Heartbeat interval used (in seconds): 10
rabbit_jobs_1 | I, [2019-03-08T06:42:28.640677 #1] INFO – #<Bunny::Session:0x5625c9b50488 admin@mqtt:5672, vhost=/, addresses=[mqtt:5672]>: Heartbeat interval used (in seconds): 10
web_1 | Started POST “/api/rmq/vhost” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#vhost as JSON
web_1 | Parameters: {“username”=>“admin”, “vhost”=>"/", “ip”=>"::ffff:172.18.0.9"}
web_1 | Completed 200 OK in 1ms (Views: 0.7ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/vhost” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#vhost as JSON
web_1 | Parameters: {“username”=>“admin”, “vhost”=>"/", “ip”=>"::ffff:172.18.0.9"}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
mqtt_1 | 2019-03-08 06:42:28.657 [info] <0.649.0> connection <0.649.0> (172.18.0.9:47420 -> 172.18.0.6:5672): user ‘admin’ authenticated and granted access to vhost ‘/’
mqtt_1 | 2019-03-08 06:42:28.657 [info] <0.646.0> connection <0.646.0> (172.18.0.9:47418 -> 172.18.0.6:5672): user ‘admin’ authenticated and granted access to vhost ‘/’
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“admin”, “vhost”=>"/", “resource”=>“queue”, “name”=>“api_log_workers”, “permission”=>“configure”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“admin”, “vhost”=>"/", “resource”=>“queue”, “name”=>“resource_workers”, “permission”=>“configure”}
web_1 | Completed 200 OK in 1ms (Views: 0.6ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“admin”, “vhost”=>"/", “resource”=>“queue”, “name”=>“api_log_workers”, “permission”=>“write”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“admin”, “vhost”=>"/", “resource”=>“queue”, “name”=>“resource_workers”, “permission”=>“write”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“admin”, “vhost”=>"/", “resource”=>“exchange”, “name”=>“amq.topic”, “permission”=>“read”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“admin”, “vhost”=>"/", “resource”=>“exchange”, “name”=>“amq.topic”, “permission”=>“read”}
web_1 | Completed 200 OK in 1ms (Views: 0.6ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/topic” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#topic as JSON
web_1 | Parameters: {“username”=>“admin”, “vhost”=>"/", “resource”=>“topic”, “name”=>“amq.topic”, “permission”=>“read”, “routing_key”=>“bot..logs", “variable_map.username”=>“admin”, “variable_map.vhost”=>"/"}
web_1 | Completed 200 OK in 2ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/topic” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#topic as JSON
web_1 | Parameters: {“username”=>“admin”, “vhost”=>"/", “resource”=>“topic”, “name”=>“amq.topic”, “permission”=>“read”, “routing_key”=>"bot.
.resources_v0.#”, “variable_map.username”=>“admin”, “variable_map.vhost”=>"/"}
web_1 | Completed 200 OK in 1ms (Views: 0.6ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“admin”, “vhost”=>"/", “resource”=>“queue”, “name”=>“api_log_workers”, “permission”=>“read”}
web_1 | Completed 200 OK in 1ms (Views: 0.5ms | ActiveRecord: 0.0ms)
web_1 | Started POST “/api/rmq/resource” for 172.18.0.1 at 2019-03-08 06:42:28 +0000
web_1 | Processing by Api::RmqUtilsController#resource as JSON
web_1 | Parameters: {“username”=>“admin”, “vhost”=>"/", “resource”=>“queue”, “name”=>“resource_workers”, “permission”=>“read”}
web_1 | Completed 200 OK in 1ms (Views: 0.7ms | ActiveRecord: 0.0ms)
parcel_1 | ✨ Built in 31.64s.
typescript_1 | [06:42:55] Found 0 errors. Watching for file changes.
typescript_1 |


#3

Next Step down

Still same errors in the above post

I logged into Farmbot on the server PC into the web-app and it gets full connection, movement the works 100% no issues great! pretty excited

however
On the client PCs on the domain network I get the error attached. This is an issue as I’ll be using PCs from all across our school site to manage farmbot

Suggestions would be appreciated

Note: network is proxy’d and firewalled heavily this i already know but If i know where/what the issue is generally I can make it work

The server is also running on the same domain but works though


#4

Can you post your .env file?


#5

@txmit1 It looks like the API and message broker are able to talk to each other, but something is stopping the bot from talking to the broker.

The FarmBot developer docs outline the usual ports that are required, and I would bet that something on your LAN if blocking the bots access to port 5672 (AMQP protocol). Do you think this could be the issue?


#6

@RickCarlino, (and @connor) that AMQP port looks odd … on v7.0.2-beta, my bot seems to be using port 5672 :confused: to reach CloudAMQP.

See this recent post


#7

Whoops! You’re right- it’s 5672. I think 5673 is a legacy port from before the node switchover that happened last month. I have updated my docs accordingly. Thanks for pointing that out.

CC: @txmit1


#8

This could very much be the issue, I’ve left a job with out IT Security team and they are checking it all out presently hopefully they will have an answer for me soon.