Lost coordinates after moving


We have an issue with the coordinates of our Farmbot, when we are making a movement, the coordinates on the webpage changes accordingly to the movement we make, acting like normal, but when it stops the stored coordinates resets to 0, making the bot thinking that it doesn’t moves at all (witch is false), we suspect that the problem comes with the acquisition of the incremental encoder’s values.

We have tried to return to an older version of Raspberry Farmbot OS (6.4.9) and it works again, so the problem only appear on the newer version (6.4.11).

Below you can see a video capture of the troubleshooting :

We hope that we are not the only one with that problem ! And hopping for anyone to help us !

Correct. In some cases a reboot may resolve the issue. As a workaround, if you disable the encoders in the Hardware widget the coordinate readings should appear as expected again. Which hardware version is your FarmBot?

Thank you very much for your response !! :slight_smile:

Unfortunately, not here it seems. We tried several times but with the last Farmbot OS version (6.4.11), it doesn’t change anything.

Thank you for your advice, we will investigate this next days. We will notice you if it helps.

We are not sure wich one it is, but our farmDuino card board number is 3317 (the one under your logo and link “farmbot.io”). Does it help you ? How can we find this hardware verison if it’s not ?

Thank you again !!
Best regards