Measure soil height - "Couldn't find surface"

I just setup a soil-level measuring sequence that scans entire garden and I’m getting an error randomly on some pictures that says “Couldn’t find surface”. Is there something I can tune to prevent this?

Assuming your axes are moving smoothly, there aren’t any obvious patterns to the error, and all the steps have been followed in the documentation, you may try increasing the DISPARITY SEARCH DEPTH value in Measure Soil Height Advanced settings.

Steps for generating images that you may provide for further investigation:

  • Enable show advanced settings
  • Open the Measure Soil Height section of the Photos panel
  • Click Advanced
  • In the IMAGE OUTPUT dropdown, select the “stereo inputs” option
  • Provide the two stereo images generated at the location where the “Couldn't find surface” error is encountered

Be sure to revert the IMAGE OUTPUT option to “colorized depth” and disable show advanced settings if desired when you are done.

2 Likes