Message broker not communicating with farmbot. "Failed to start child" "enoent"


I am still reading through old troubleshooting posts but haven’t found the solution yet.

After completing the farmbot except for the UTM and connecting the peripherals, I decided to try connecting the farmbot and testing the motors before doing the final bit.

I flashed the FarmbotOS onto the SD card, and got the configurator. Had some errors, wifi, then word password. Resolved those. Then couldn’t the farmbot to work (the webapp wouldn’t connect to the farmbot), it was connecting to my friend’s phone and then failing and rebooting. We got the following errors attached, and the diagram explains there was a problem with the message broker, most likely a bug (couldn’t be a firewall issue as it was connected to my friend’s phone with no security).

I grabbed the raspberry pi and Arduino to tinker while away from my farmbot, I’m actually living 2.5 hours from where it is. Is there anything I can do with just those components to try to resolve it? Will be on site this Sunday.

hi Tim
i’m feeling less alone…
same issue for me and i manage myself the firewall, wifi and WebApp

same as : Dont config 6.0.1
and :

Do you have reproduction or genuine arduino ?

does it work in 5.0.9 ?

1 Like

Hey Renaud

I have an Arduino mega 2560, made in china too probably.

I started the config with the Arduino not connected to the raspberry pi and it work! I then plugged in the Arduino and it seems to be working. I’m just testing these components now and will try it with the whole bot on the weekend. will keep you updated.

haven’t tried 5.0.9


issue solved with a new arduino, not genuine but not low cost…

let’s try this new farmbot_os !!

Hey Renaud

Where did you buy it? Which site?

Got it to work by plugging in the Arduino after connecting the Raspberry Pi, but when I plug in the RAMPs shield it stops working :frowning:

it’s an arduino that costs about $25, the previous one was to cost $7 …
I bought it in an electronics store near my house …
velleman, an european electronic constructor… but i think any quality contructor can work …

just to check, do you cut the power before reconnecting?

Ah no I haven’t tried that on purpose. But have disconnected and tried that a little bit, like I have tried a couple time now.

Are you still getting the Failed to start child: Elixir.Farmbot.Firmware reason: {:handler_init, {:error, :enoent}} error? A new Arduino should resolve the issue if the error occurs with only the Arduino plugged in. If the error only occurs after RAMPS is plugged in to the Arduino, there may be a short in the RAMPS board or connections.