Motor stuttering


#1

Hello,

I’m having an issue where the y-axis motor is stuttering. See video for clarity. It’s also “crunchy” when I manipulate the motor. Does anyone have any ideas on what this behavior might indicated?

Motor Stuttering

Cheers!


#2

I had this exact same problem. Swap the stepper drivers of two motors and see if the problem moves to another motor.

If it does, it means your stepper driver is fried.


#3

The problem followed the motor, not the driver. Although, the performance of the motor was slightly better. See attached. y-axis motor stuttering on z-driver This may indicate that the driver needs to be tuned. It started raining so I wasn’t able to tune nor try a different motor on the original driver.

Thoughts? Is this pointing to a bad motor?


#4

It could be the motor, but your best bet would be to completely rule out the drivers first. So, using a multimeter, read out the voltage it’s giving. Use our FAQ on movement issues to see how to do that step by step (it’s the last chapter of the article).


#5

Thanks for the link Marc. It seems that I’m in good company as you’ve solved similar issues.

My leading theory is that the Y-axis motor cable is fault.

Here’re my findingst:


#6

To rule out crosstalk, you should connect the motors with the wires outside of the cable carriers.

If the motors work fine when the wires can’t interfere, you may need to redo the cable carrier layouts. Keep the wires for each motor as far away as you can. For example, Y cable on far left side, water and vacuum tubes in the middle and Z cable on the far right.


#7

Not sure that this makes any sense, cross-talk (if it occurs at all) will be from the motor drive to the encoder feedback, I doubt you’ll get crosstalk between feedbacks (and absolutely not at all between the drives, being low impedance). If you suspect a problem with the feedback signals, the first course of action should be to connect the cable screen. This is the small black wire which should be connected to a 0V somewhere on the RAMPS board. Otherwise, try terminating the feedback signal (between A and AQ, and between B and BQ) with something like a 220 or 330 ohm resistor, that will improve matters MUCH more than physically separating the wires.

In reality, cross-talk will be intermittent and have mild effect, I’d be looking at more fundamental problems like motor drive current first.


#8

Thanks for weighing in. Troubleshooting really is a group effort most of the time.


#9

Thanks fellas. I’ll be checking the 0V connection as soon as the weather clears. I should also state that I disabled the encoders during this troubleshooting to isolate the problems to just the drive circuitry.

Loveny, do you have any ideas about a potential source of drive current issues?

I have cranked up Vref to 11: problem remained
I have set the Max Speed, Min Speed, and Acceleration all to 1 in attempts to slow down the signalling: problem remained

I have swapped motors and kept the stepper drivers/port/cable constant (y-axis port): both motors exhibit the same behavior on the Y port, did fine on the Z port.
I have swapped the stepper driver: the problem remained on that port (although, it did get slightly better and the other motor continued working)
I have swapped the motor and cable between ports (Z and Y): the problem was still exhibited by both motors on the suspect Y-port (and performed fine on the Z port/cabling)


#10

You can increase Vref up to about 1.2V if you need to, but it sounds more like a cable issue. The connectors are pretty delicate, especially the ends which plug into the motors. If you pull on the cable rather than the connector then you will damage them, very easy (I’ve done it myself!).

To check the cable; leave the cable plugged into the motor, and unplug from the RAMPS board. You should get a short between black and red, and another short between white and yellow. There should be no connection between red and either white/yellow, or between black and either white/yellow. Similarly, there should be no connection between yellow and either black/red, or between white and either black/red.

Be very clear about which motor you swap and/or which cable is swapped between drivers, sometimes you can change two variables and get very confused about where the real problem is.

Hope that helps,
Jon


#11

Hey Jon,

Sorry for the delay. Unfortunately my robotics habit keeps getting interrupted by family and work habits.

Here are my latest efforts:

I bought new motor drive cables to create a test rig. I physically removed the x1 and y motors from the CNC rig, took the electronics and power supply inside. I performed the continuity tests on the new test cables as you suggested, and they performed as expected. Upon hooking up the test rig, I confirmed that both motors work as they should (bi-directional control, proper stepping) when connected to the Y, Z, and X1 ports (I have a suspect X2 port issue as well).

This seems to confirm my earlier testing that the Y-axis cable is at fault. It may likely follow your experience and I have physically compromised connectors. I will take the testing rig back outside, perform the continuity test on the production cable, and perform the final isolation testing at my next opportunity.

Thanks for the support Jon!


#12

Hey all,

Last night I hooked up my newly repaired board set (please see X-1 motor does not change direction). During bench tests with a different cable harness, the problem did not present itself. Upon using the OEM cable installed in the rig, the problem persisted. Then the great sky darkened and the skies let loose a terrible deluge. I’ll get to ringing out the OEM cable as you mentioned @Loveny in the next few days after this weather front passes.

Cheers,
Mike


#13

Jon,

Ringing out the ends produced odd results. I was getting no connectivity between R and B, but was getting connectivity between W and Y. I also got some connectivity between R and W. I disconnected the cable, and tested the motor directly to make sure I wasn’t insane. It was fine, but didn’t match the pattern on the connector. That’s when I noticed the connection pattern on the motor end of the cable was different from the other ends: the R wire was attached to the socket directly adjacent to the black wire! There was a manufacturing defect!. I was able to lift the R pin’s catch, remove the pin and place it in its proper place: in the #3 position (assuming black is #1 position). It worked like a champ after that.

Thanks for keeping me honest :smile:

Kind regards,

Mike


#14

Great result, well done :slight_smile:


Problems with X and Y axes
#15

5 posts were split to a new topic: Controlling all four motors


#16

A post was merged into an existing topic: Controlling all four motors


#17

For my case, almost the same situation about the y-axis motor happened.

I troubleshooted according to your methodology and found A4988 Driver of the y-axis controller was dead. And the extra one, on the AUX motor controller was also dead ( I swapped them at the first time and found the symptom worsened so I thought the problem was not about drivers but later I found BOTH of them died.)