Motors don't run

I have assembled and configured the farmbot. It connects to the web app just fine.When I try to move the farmbot using the controls widget, it does not move even though the app shows that the movement is successful. There is no sound from the motors. All the connections seem to be correct. Any suggestions?

How does your connectivity panel look like, can you post a screenshot pls?

This is how the connectivity panel looks like.
I did have a problem with the Arduino connectivity last week. Solved it by replacing the old Arduino with a new one. I was under the impression that the firmware on the arduino would be uploaded automatically when i reconfigure the farmbot. Is that so or do I have to manually update the firmware onto the arduino board?

When I try to take pictures I get an error saying pics cannot be taken.
I have checked all the connections four or five times and all of them are according to the pin diagram.

I even get the following error during boot up: Trying to resolve 9 more times.

I can’t figure out what exactly is wrong. Any help would be greatly appriciated

Did you check your Camera setting in the device section? Also try to reboot the device.

As long as you only get this error while booting you don’t need to worry about it.

@Ascend Yeah I did check Camera setting in the device section, it is set to USB camera. Also tried rebooting the device but nothing changed.

Could you provide an image of the error? I guess it appears in the logs and was caused by the farmware.

This is a screenshot of the logs. And even though it says movement is sucessful, the motors do not physically move at all

Your arduino seems to communicate properly. This rather looks like a power issue on the Ramps board, which is on top of the arduino board. Make sure that the green connector is correctly connected to your 12V power source and the polarity is right. Maybe you are even able to measure the voltage on that connector.

I had checked the voltage at the green connector using a voltmeter and there seems to be 12V supply going in. There is no light on the ramps board though. Is there any other way to check if the ramps board is working or not.

You could try to turn peripheral Pins on, those should also light up a LED.

I checked the ramps board by switching on the peripheral pins as suggested and the LED lights up without any problem.

Another query that I have is should the stepper driver voltage read exactly 600mv or is it ok if it is a little less than 600 like around 570mv or something?

SImply go in the Controls tab and toggle the switch of one peripheral pin to on.

I did that and again everything seems to be working fine.

I guess you refer to mdingena’s post in the faq section:

Please not the part that I marked with strong characters. Are you still using the original stepper drivers (A4988)?

Yeah correct I was referring to same post.
I am using the original stepper drivers.

I would try to increase the Vref of a single stepper driver to see if the motor does even react.
Did you check the orientation of the stepper drivers? Here is how it should be:

The orientation of the stepper drivers are correct. And I tried to increase the Vref but still none of the motors moved. They were working fine before I had to change the arduino board due to connectivity issues.

Is it possible that the stepper drivers are fried? I am able to increase or decrease the Vref, so not sure of it.