No 5V on Pin A for UTM

Hello everyone!

I’ve developed a new pruning tool for the Farmbot that works in a similar fashion to a radial trimmer (weed whacker). The motor requires a 24V power supply, but I would like to control the power via a 5V relay. I noticed while testing that the 5V on the UTM (Pin A), was not working. I brought a volt meter and found no voltage between pins A and B. I even tried attaching the Soil Sensor incase this was something to do with tool verification, but still noticed soil sensor itself isn’t getting the 5V power.

My question is, do we need to enable the 5V somewhere in the settings of the Farmbot?

Thank you in advanced for your help!

1 Like

Hi @markt that sounds like an interesting project!

Which FarmBot model do you have?

Hi @RickCarlino

I have a Farmbot Genesis 1.4. Got it in May of 2019.


5v is enabled through the pin jumpers installed by default on the Farmduino board. You can see them in the documentation figures just to the right of the UTM cable connector. If the jumpers are present and the UTM connector is firmly plugged into the Farmduino, you could check the connection and orientation of the other end of the cable that plugs into the UTM.

1 Like

The issue was the UTM cable not fully secured to the UTM pcb headers. Thank you for pointing that out, it works now!