No connection to Arduino

Hey together!

Some weeks ago we built the FarmBot Genesis together as a team. It worked fine so far. Unfortunately today it stopped working. I can’t get the FarmBot to move anymore. Even turning the lights on doesn’t work.

Here’s what I tried so far:

  • Reflashed the RPi
  • Changed the RPi for a new one
  • Changed the microSD card
  • Plugged the Arduino (Farmduino) board to my computer and started the serial monitor (see screenshot)
  • unplugged all stepper motors + encoders
  • unplugged all peripheral devices (water pump, vacuum pump, LED lights)
  • unplugged UTM

What’s noticable is, that the TX led of the Farmduino keeps blinking all the time. Most likely because of the GCodes it’s sending via the USB serial port.

TBH I’m out of ideas and hopefully some of you guys can help me. Feel free to ask, if you need to know more.

Thanks in advance!

  • Sebastian

GCodes receiving from the Farmduino, when I connect my computer with it.

Device settings and status.

Well… After 2-3 hours of working on this problem, I wrote this post. Less then 10 minutes later, I figured it out… I reattached the Z-Axis motor and encoder cables and now it’s back working. I’ll leave this here, if anybody got the same problem. :smiley:

A post was merged into an existing topic: connection issues

Glad you figured it out! As you’ve mentioned, the disconnected Z-axis motor and encoder was the issue. Because you had FIND HOME ON BOOT enabled, the boot sequence was waiting for feedback from the encoder that it never received since it was disconnected.

1 Like