Not updated coordinates

Hi everybody !
When I request a move in the Controls tab, the bot moves, but the coordinates remain unchanged on the app. It’s the same thing in the Farm Designer tab when I ask to move to this plant. It doesn’t refresh.

@CoutancesNature A few questions:

  • What version of FarmBot OS are you running?
  • What model of hardware are you running?
  • How does your connectivity panel look (see photo below)

We are running on v8.0.4. This problem appeared with v8.
The hardware is Genesis XL v1.4
The connectivity panel looks like this (image below), but all was green before our tests5 hours ago.!
Thank’s for your help !


How does this part of the Device widget look:

I suspect that a wrong firmware is chosen or its not working properly.

Indeed, it seems that there is a problem of firmware.
I wait for your opinion before clicking on “Flash firmware”.

Alright, now try to flash the firmware by clicking the FLASH FIRMWARE button.

Hello !
I flashed the Firmware, and all lights are green now.

However, the robot continues to act the same way: after a command in the control tab, the robot moves, but the app does not reccord the movement. (Sometimes the movement is reccording several hours later)

I don’t understand,but it seems working tonight.
At 11:30 this morning, I requested a movement of 100 mm on the X axis, and I just discover these messages in the Logs :

Can you explain what happened ?
I will continue testing tomorrow morning.

Is my problem related to my attempt to install the Powerloop farmware on v8 ?

Not sure what exactly you mean, but the device reconnected at 16th October. At this time the position was 100,100 which seems to be right.

Are you experiencing any connection issues?

Did you run into any issues when you installed the farmware? Its working on my device.

Yes, it’s the right position, but only after 7 hours !

I don’t know how to detect connection issues…

I just tried to install Powerloop, and the installation seems to have worked. But when I run a sequence with Powerloop, I have a lot of messages in the Logs, but the coordinates in the app don’t move (Tonight at home, I can not see if the bot moves)