Photos not complete

After running weed detect across my Express XL garden, after a while of several successful photos, photos begin only being partially captured. The detect weeds session keeps advancing to the next points and “processing” continues, but no more weeds are found and the photos are not downloaded. This has occurred many different detect weeds sessions and every time I run a session. I can only fix the issue by power cycling or doing Settings-> Power and Reset->Restart Farmbot.

I can use the camera and manually snap a photo, so here is an example of some of these partial photos.



@Davejavu We are suspicious this is a software issue rather than a problem with the camera (mainly because reboots seem to temporarily help). I will need to dig deeper to know for sure. I’ve got a few things in my queue ahead of this issue, so it will be a bit before I begin investigating.

Since you mentioned in another thread that you are bumping against the point limit in a different thread today, can you please try deleting as many non-essential points as possible? Eg: weeds that the weed detector found, generic points that you are no longer using, etc…

I will give you a full reply about that issue in the appropriate thread, but I am curious to see if the number of points in your garden is over burdening the RPI0’s CPU which might cause a trickle down effect to the plant detection system.

While waiting for the replacement of the defective camera, lots of weeds grew. I can certainly delete these points/weeds. However, at last count of one detect weeds cycle before failure the software reports 767 pending weeds with less than half of the garden scanned. Running the weed detection routine will just add all of them back in. This count is after I tried to get a handle on the weed problem by covering most of the garden with aluminum roofing scraps as seen in the photo. I am not sure how to proceed since, as you can see, most of the actual soil is covered and it’s still detecting most likely a few thousand weeds…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.