Pi and Farmdunio wont talk

Hi there.
My farmbot did not do the latest software update and had crashed, so this morning I reflashed the software to installed farmbot-rpi3-10.0.0. on the SD card. After setting up the ethernet connection, I could now see the farmbot, but the Pi and arduino/ramps(farmduino) were not connecting. See the attached image. We are getting error code 30. The farmbot is a V1.2

So we checked the cables, replaced the USB cable, replaced the Pi, replaced the Ramps, Replaced the aduino. We removed all the motors and cameras from the system as well to We did each of these one at a time, doing restarts and factory resets between each change of hardware and all to no avail. We still get the same error like the image shows.

Does anyone have any thoughts as to why this is happening?!
FarmBot error|690x387

Hey @RTipping
your device will most likely run again if you flash the OS version 9.2.2. Afterwards you can update the device via OTA to 10.0.0, but directly flashing 10.0.0 will cause issues.
We’ve only seen this issue to happen on 3rd party arduino boards that were not shipped by FarmBot. Are you running on a kit from FarmBot?

1 Like

Thank you so much Ascend.

That is 100% what the issue was. I do have my own boards that were not shipped from farmbot. I have now re flashed with the out of date software and it came straight up. I am now doing the upgrade via the interface.

Thank you for getting me going again.