Problem about Farmbot Web APP v5.1.0


#1

Hi

I have success to build run Web server and mqtt-gateway-master on VM bot and can control my raspberry pi. These day I’m trying to turn the Web App to 5.1.0. I can done everything in my VM box, but when I try to use the Web APP I got this:


Enter the url below it show this:
url_wrong
But looking in the command window of mqtt broker, the Web app has success connect to the broker.

At first I think this may cause by my firewall setting. I change the default rules of my VM to ACCEPT and add exception of IP to AVG on my host computer. It doesn’t solve the problem. Using curl command in my host computer to GET the /webpack/bundle.js it stop at chunck 12, but in the VM it get got about more than 900.

Also find that some people solve the problem about dynamic page by upgrade the webpack version. I use the yarn to upgrade it. It still not slove.

Using the google chrome developer tools I think the problem is about the localhost.
Below is in my host:

And here is on VM:


Finding that the 13.js is under localhost. Is this this the problem why I can use the Web APP with out in the VM box? How can I solve this problem.

Appreciated for any response.


#2

@mophy85 Running rake api:upgrade will update your API to the latest version.

Are you sure you are using real IP addresses in application.yml? You cannot use localhost in application.yml.

Check the value of MQTT_HOST and API_HOST to make sure they are using valid IP addresses.


#3

@RickCarlino Thanks for replying. Yes both of the MQTT_HOST and API_HOST is using my ip on VM. I have also use that IP to run an simple express website to make sure it is fine. Today I have try rebuild the database and rebuild with npm rebuild node-sass --force. Still the same situation. But when I use the rake api:upgrade I got rake aborted(Picture below). Does this mean I didn’t correct install something?
4


#4

@mophy85

You might be running an older version that did not support that command.

you can manually update with git pull https://github.com/FarmBot/Farmbot-Web-App.git master and starting over.


#5

@RickCarlino Thanks for replying.

Today I have try the master version. Also try to download from the github and starting over. Unfortunately have the same problem.

Below is what I set in application.yml.

API_HOST: “140.138.55.149”

PORT: “3000”

DEVISE_SECRET: rake secret

OS_UPDATE_SERVER: “https://api.github.com/repos/farmbot/farmbot_os/releases/latest

MQTT_HOST: “140.138.55.149”

SMTP_PORT: “587”

NO_EMAILS: TRUE

Is there anything wrong or missing something?


#6

@mophy85 When I paste your config into my text editor, I see that you are using and as quotation marks. This usually the result of editing files in MS Word or Open Office. It can cause issues. For best results, I recommend using a text editor rather than a word processor. VS Code is my personal favorite.

It should be:

"10.0.0.15"

rather than

“10.0.0.15”

Please let me know if that helps.