Problem sending RPC command Sequence not found

I am having trouble getting started. I have farm bot calibrated and tools mapped…

Now i am working on sequences… I tried running my first sequence by hitting the test button and I got “Problem sending RPC command Sequence not found” See screenshot.

Hi @jorrflv

Usually when auto-sync is enabled (and it does look like your account has it enabled from looking at the screenshot) data changes are automatically sent to the device. Sometimes, usually due to momentary network issues, the new data does not get auto-synced with the device. To trigger a manual re-sync with the device, you can click the word “Synced” on the gray navigation bar. If that still does not fix it, a reboot may help. I can remotely inspect your device (given that it is connected to the internet) if that still does not fix the issue. Please let me know and I will take a look.

You are right @RickCarlino, reproducible bug every-time i edit the sequence… it auto syncs and then i have to manually sync to get the sequence to run.

When i try to dock a tool i keep getting an x-axis stall error because the resistance is too much to break the magnet as it tries to slide the tool in to the dock. any tips there?

@jorrflv The magnet issue sounds like a problem with motor tuning, possibly with stall detection which is not an uncommon thing during initial setup.

The auto-sync issue is a bit more concerning, as it may indicate a network issue. Can you please send a screen shot of the connectivity panel (can be seen by clicking the green dot on the nav bar). Have you noticed any “flickering” with connectivity or disconnect issues? Is the device particularly far away from the access point? This is the first report we are hearing of this and I am unable to reproduce with my local device.

@RickCarlino Can you point me in the direction for help with motor tuning… I get the stall error frequently.

@jorrflv the solution to the motor stall is usually to reduce the speed by 10 until it dosn’t stall anymore.

Are you able to show take a video and speak on the video to tell us what the FarmBot is doing? Post it to YouTube and then post the video in the link. Others can learn also if you post the video.

@RickCarlino Here is the video of the farmbot trying to unmount the water nozzle…

@jorrflv review your videoclip between 29s and 30s and you’ll see the tool rotate into the UTM as it springs out from the tool slot. Suggests to me that the Z should be 6 mm closer to the tool before the X-axis starts to withdraw it. I don’t have enough knowledge to suggest why the Z is too far away from the tool before FBOS/firmware assumes that it’s mounted . . I thought there was a Mounted sensor that was in “in the loop” during that operation ? @RickCarlino will know :slight_smile:

I wonder whether this is all due to the v1.5 firmware bugs related to homing and calibration ( very recently squashed but new firmware not yet released ) ?

Your tool is not supposed to rotate when it is pulled out of the tool bay. The reason for that is probably that the magnets polarization of the tool mount does not fit to the the tools. You seem to own a new express device, that comes with most parts already pre-assembled. Maybe those magnets were mounted in the wrong orientation.

@Ascend , @jorrflv owns a

Here is a video of me trying to find home on the FarmBot. It is a genesis 1.5 running 9.1.2

@jorrflv Have you tried turning the tools around so that the text on the tools lines up with the logo on the UTM?

@RickCarlino what is the status on the homing bug in the 1.5 genisis… I am getting really frustrated trying to get the bot to work, because it seems noting is consistant because home is never verified

@jorrflv Have you upgraded to FBOS v9.2.0 (released this morning)? v9.2.0 contains numerous firmware bug fixes. If it does not fix your issue please let me know and I will continue investigating.

1 Like