Relative movement failed

hey guys,

got a new farmdunio 1.4v the other day to replace a doa farmdunio.
i can manually move it using controls page. but every time i get a error saying relative movement failed on all 3 axes.
motor coordinates(mm) and scaled encoder(mm) show 0 all the time and raw encoder data shows -1
i turned off power to the motors and moved them by hand to see if any of the motor coordinates or others changed but nothing changes.

thanks in advance

So if you run an axis in one direction, it actually complete its movement but its not detected by the software?

Sounds like your encoders are not properly connected. Make sure that you chose the right farmduino board in the device section.

hey @Ascend,

sorry i havent gotten back in months!! wether got crap then got busy at work and other projects.
i atempted to run the farmbot again. i reinstalled the firmware again 1.4v farmduino. can jog all moters ether way. (z is quite loud) checked the voltage at the output from the board and at the input to the encoder around 5.05Vdc. shows as -1 in raw data and if i flip it on the webpage it goes to 1. but it never moves when i move it by hand or jog it via app. everything else that i have tested so far works as it should. any ideas how to foult find this issue?

So the Firmware filed is filled with the name of your connected board (Farmduino Genesis 1.4)?

You are using the encoders from the kit that came with the connectors that fit to the farmduino board?

Filled with Farmduino (Genesis v1.4) with green tick. And everything is from the box.

Hm i’m out of ideas already, maybe @Gabriel knows something that we are missing? :slight_smile:

Power cycling (unplugging the Farmduino from the power supply and plugging it back in) may help if that has not yet been tried.

Definitely have tried that multiple times.
Haven’t tried reflashing the card via computer for a while(early March) Will try that tomorrow.

If movements complete successfully with encoders disabled on a v1.4 Farmduino, then the correct firmware has been selected and the issue is restricted to encoder position reporting. However, if the encoders are unplugged or not reporting to the Farmduino, the raw encoder position values should read 0. -1 can indicate an error internal to the Farmduino, which a power cycle usually resolves. Can you try installing and running this Farmware to reset encoder tracking and check if the raw encoder position values report 0?

hey Gabriel,

i have reflashed the farmduino. still getting -1 on all 3.
tryied the farmware to reset encoder tracking. still shows -1.
i have spare pi3’s and arduinos so i can test the encoders if someone tells me which file to load and the pinout to use to test the encoders.

If the raw encoder positions still show -1 after the tracking reset with the encoders unplugged, it’s likely the issue is with the Farmduino rather than the encoders.

If you do want to test the encoders, you could load FarmBot OS on a Raspberry Pi connected to an Arduino Mega and select Arduino/RAMPS (Genesis v1.2) for the firmware during configuration. The encoders can then be attached to any of the following pins for testing (in addition to 5v and ground):

axis encoder wire pin
X A (white) 16
X B (green) 17
Y A (white) 23
Y B (green) 25
Z A (white) 27
Z B (green) 29

sorry its taken forever for me to reply!!

just did the test with the arduino/pi3 with farmbot os. its reading the encoders fine :frowning:
already had a doa farmduino 1.4 board and got replaced with the board and its not working ether :frowning:

guess i better contact in contact with Rory again